summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.75.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-26 08:34:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:02 +0100
commit6287ef4865b00306552439ec3be5255ad9ce94b7 (patch)
tree0b11778864f3cfb4c1065c3a6a0837fa8987e8fb /meta/recipes-extended/lighttpd/lighttpd_1.4.75.bb
parent9e668051872ed370feedd32331380f51f0ecde2e (diff)
downloadpoky-6287ef4865b00306552439ec3be5255ad9ce94b7.tar.gz
lighttpd: upgrade 1.4.74 -> 1.4.75
Changelog: ========== * [mod_redirect] url.redirect-code = 308 new default * [ls-hpack] more portability fixes for sys/queue.h * [ls-hpack] update version to 2.3.3 * [TLS] default to stronger ciphers w/ PFS and AEAD * [ci] apt-get install build-essential on Ubuntu * [ci] /usr/local/opt keg-only pkgs on Darwin(macOS) * [mod_authn_sasl] translate SASL_LOG_* to syslog * [build] include src/compat/sys/queue.h in tarball * [core] fdlog_openlog(), fdlog_closelog() * [mod_accesslog] fdlog_openlog() if using syslog * [cmake] fix LEMON_PATH with empty CMAKE_BUILD_TYPE * [ci] limit github ci to specific branches * [ci] prefer non-login shell for Cygwin CI build * [ci] prefer dash for Cygwin and MSYS2 builds * [mod_wstunnel] fix server.ping-interval w/ HTTP/2 * [mod_dirlisting] fix suffix display of '/' on file (fixes #3242) * [mod_openssl] use internal asn1_time fn on 32-bit (fixes #3244) * [mod_openssl] faster ASN1_TIME parse * [mod_wolfssl] faster ASN1_TIME parse * [doc] update TLS comment in sample lighttpd.conf (From OE-Core rev: a3c74e93469dd3a40a17dd04971f79af6701a2ad) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.75.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.75.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.75.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.75.bb
new file mode 100644
index 0000000000..fc3b7e005d
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.75.bb
@@ -0,0 +1,76 @@
1SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3DESCRIPTION = "Lightweight high-performance web server is designed and optimized for high performance environments. With a small memory footprint compared to other web-servers, effective management of the cpu-load, and advanced feature set (FastCGI, SCGI, Auth, Output-Compression, URL-Rewriting and many more)"
4BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
8
9SECTION = "net"
10RDEPENDS:${PN} = "lighttpd-module-dirlisting"
11RRECOMMENDS:${PN} = "lighttpd-module-accesslog"
12
13SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \
14 file://index.html.lighttpd \
15 file://lighttpd.conf \
16 file://lighttpd \
17 "
18
19SRC_URI[sha256sum] = "8b721ca939d312afaa6ef31dcbd6afb5161ed385ac828e6fccd4c5b76be189d6"
20
21DEPENDS = "virtual/crypt"
22
23PACKAGECONFIG ??= "openssl pcre zlib \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
25"
26
27PACKAGECONFIG[libev] = "-Dwith_libev=enabled,-Dwith_libev=disabled,libev"
28PACKAGECONFIG[mysql] = "-Dwith_mysql=enabled,-Dwith_mysql=disabled,mariadb"
29PACKAGECONFIG[ldap] = "-Dwith_ldap=enabled,-Dwith_ldap=disabled,openldap"
30PACKAGECONFIG[attr] = "-Dwith_xattr=true,-Dwith_xattr=false,attr"
31PACKAGECONFIG[openssl] = "-Dwith_openssl=true,-Dwith_openssl=false,openssl"
32PACKAGECONFIG[krb5] = "-Dwith_krb5=enabled,-Dwith_krb5=disabled,krb5"
33PACKAGECONFIG[pcre] = "-Dwith_pcre=pcre2,-Dwith_pcre=disabled,libpcre2"
34PACKAGECONFIG[zlib] = "-Dwith_zlib=enabled,-Dwith_zlib=disabled,zlib"
35PACKAGECONFIG[bzip2] = "-Dwith_bzip=enabled,-Dwith_bzip=disabled,bzip2"
36PACKAGECONFIG[webdav-props] = "-Dwith_webdav_props=enabled,-Dwith_webdav_props=disabled,libxml2 sqlite3"
37PACKAGECONFIG[webdav-locks] = "-Dwith_webdav_locks=enabled,-Dwith_webdav_locks=disabled,util-linux"
38PACKAGECONFIG[lua] = "-Dwith_lua=true,-Dwith_lua=false,lua"
39PACKAGECONFIG[zstd] = "-Dwith_zstd=enabled,-Dwith_zstd=disabled,zstd"
40
41inherit meson pkgconfig update-rc.d gettext systemd
42
43INITSCRIPT_NAME = "lighttpd"
44INITSCRIPT_PARAMS = "defaults 70"
45
46SYSTEMD_SERVICE:${PN} = "lighttpd.service"
47
48do_install:append() {
49 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
50 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
51 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}/lighttpd
52 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
53
54 install -d ${D}${systemd_system_unitdir}
55 install -m 0644 ${S}/doc/systemd/lighttpd.service ${D}${systemd_system_unitdir}
56 sed -i -e 's,@SBINDIR@,${sbindir},g' \
57 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
58 -e 's,@BASE_BINDIR@,${base_bindir},g' \
59 ${D}${systemd_system_unitdir}/lighttpd.service
60 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
61 ln -sf ${localstatedir}/log ${D}/www/logs
62 ln -sf ${localstatedir}/tmp ${D}/www/var
63}
64
65# bitbake.conf sets ${libdir}/${BPN}/* in FILES, which messes up the module split.
66# So we re-do the variable.
67FILES:${PN} = "${sysconfdir} /www ${sbindir}"
68
69CONFFILES:${PN} = "${sysconfdir}/lighttpd/lighttpd.conf"
70
71PACKAGES_DYNAMIC += "^lighttpd-module-.*"
72
73python populate_packages:prepend () {
74 lighttpd_libdir = d.expand('${prefix}/lib/lighttpd')
75 do_split_packages(d, lighttpd_libdir, r'^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
76}