summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-07-03 09:50:27 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-04 17:40:31 +0100
commit96ebfa7c5f201ea0cab50f9e3be746c8b3680278 (patch)
tree51fb227176943158bd1f73aa0e5808ed0087e956 /meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
parent5384eefe79c974a5db93aa2dc40d022dd092d592 (diff)
downloadpoky-96ebfa7c5f201ea0cab50f9e3be746c8b3680278.tar.gz
lighttpd: upgrade to 1.4.31
(From OE-Core rev: 913f4831aeb83e2c7f08daa47a31089dbf06f2be) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
deleted file mode 100644
index 161c0d964f..0000000000
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
+++ /dev/null
@@ -1,64 +0,0 @@
1DESCRIPTION = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8
9SECTION = "net"
10DEPENDS = "zlib libpcre"
11RDEPENDS_${PN} += " \
12 lighttpd-module-access \
13 lighttpd-module-accesslog \
14 lighttpd-module-indexfile \
15 lighttpd-module-dirlisting \
16 lighttpd-module-staticfile \
17"
18
19PR = "r1"
20
21SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
22 file://index.html.lighttpd \
23 file://lighttpd.conf \
24 file://lighttpd \
25 file://lighttpd_fix_for_automake-1.12.patch \
26 "
27
28SRC_URI[md5sum] = "63f9df52dcae0ab5689a95c99c54e48a"
29SRC_URI[sha256sum] = "0d795597e4666dbf6ffe44b4a42f388ddb44736ddfab0b1ac091e5bb35212c2d"
30
31EXTRA_OECONF = " \
32 --without-bzip2 \
33 --without-ldap \
34 --without-lua \
35 --without-memcache \
36 --with-pcre \
37 --without-webdav-props \
38 --without-webdav-locks \
39 --without-openssl \
40 --disable-static \
41"
42
43inherit autotools pkgconfig update-rc.d gettext
44
45INITSCRIPT_NAME = "lighttpd"
46INITSCRIPT_PARAMS = "defaults 70"
47
48do_install_append() {
49 install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
50 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
51 install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
52 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
53}
54
55FILES_${PN} += "${sysconfdir} /www"
56
57CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
58
59PACKAGES_DYNAMIC = "lighttpd-module-*"
60
61python populate_packages_prepend () {
62 lighttpd_libdir = d.expand('${libdir}')
63 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
64}