summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iputils/iputils_s20180629.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-23 13:36:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-26 13:16:40 +0100
commitb30285ca8fd049170bb13c3e80af4e8b2700427e (patch)
tree21389c2fc20f6c28a0d3e978032b5203c0664234 /meta/recipes-extended/iputils/iputils_s20180629.bb
parentce56cf535329439646ae3148323ffab059a3d706 (diff)
downloadpoky-b30285ca8fd049170bb13c3e80af4e8b2700427e.tar.gz
iputils: upgrade to s20190629
License-Update: change license checksums to check the License files themselves (BSD3 and GPL2), and the tool-to-license file (LICENSE). Changes to LICENSE will now be detected. Backport a patch to fix the build with musl. Drop upstreamed patch. Update libidn build-dependency to libidn2. Patch in an install target and use that to install binaries, to avoid upstream adding binaries that we don't ship. Also ship all binaries that are installed. (From OE-Core rev: d227122d929330ff71a550689aaedc5d8299d859) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/iputils/iputils_s20180629.bb')
-rw-r--r--meta/recipes-extended/iputils/iputils_s20180629.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-extended/iputils/iputils_s20180629.bb b/meta/recipes-extended/iputils/iputils_s20180629.bb
new file mode 100644
index 0000000000..eff44be1bd
--- /dev/null
+++ b/meta/recipes-extended/iputils/iputils_s20180629.bb
@@ -0,0 +1,61 @@
1SUMMARY = "Network monitoring tools"
2DESCRIPTION = "Utilities for the IP protocol, including traceroute6, \
3tracepath, tracepath6, ping, ping6 and arping."
4HOMEPAGE = "https://github.com/iputils/iputils"
5SECTION = "console/network"
6
7LICENSE = "BSD & GPLv2+"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=b792e38abdc59f766a3153908f23e766 \
10 file://LICENSE.BSD3;md5=0f00d99239d922ffd13cabef83b33444 \
11 file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13DEPENDS = "gnutls libcap libgcrypt"
14
15SRC_URI = "git://github.com/iputils/iputils \
16 file://ai_canonidn.patch \
17 file://install.patch"
18SRCREV = "f6aac8dbe3f8c45c53424854a3312bdd8cdd58d3"
19
20S = "${WORKDIR}/git"
21
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>s\d+)"
23
24EXTRA_OEMAKE = "-e MAKEFLAGS="
25
26PACKAGECONFIG ??= ""
27PACKAGECONFIG[libidn] = "USE_IDN=yes,USE_IDN=no,libidn2"
28
29do_compile () {
30 oe_runmake 'CC=${CC} -D_GNU_SOURCE' VPATH="${STAGING_LIBDIR}:${STAGING_DIR_HOST}/${base_libdir}" ${PACKAGECONFIG_CONFARGS} all
31}
32
33do_install() {
34 oe_runmake DESTDIR=${D} bindir=${base_bindir} install
35 for b in ping traceroute6 clockdiff; do
36 chmod u+s ${D}${base_bindir}/$b
37 done
38}
39
40inherit update-alternatives
41
42ALTERNATIVE_PRIORITY = "100"
43
44ALTERNATIVE_${PN}-ping = "ping"
45ALTERNATIVE_LINK_NAME[ping] = "${base_bindir}/ping"
46
47SPLITPKGS = "${PN}-ping ${PN}-arping ${PN}-tracepath ${PN}-traceroute6 ${PN}-clockdiff ${PN}-tftpd ${PN}-rarpd ${PN}-rdisc"
48PACKAGES += "${SPLITPKGS}"
49
50ALLOW_EMPTY_${PN} = "1"
51RDEPENDS_${PN} += "${SPLITPKGS}"
52
53FILES_${PN} = ""
54FILES_${PN}-ping = "${base_bindir}/ping.${BPN}"
55FILES_${PN}-arping = "${base_bindir}/arping"
56FILES_${PN}-tracepath = "${base_bindir}/tracepath"
57FILES_${PN}-traceroute6 = "${base_bindir}/traceroute6"
58FILES_${PN}-clockdiff = "${base_bindir}/clockdiff"
59FILES_${PN}-tftpd = "${base_bindir}/tftpd"
60FILES_${PN}-rarpd = "${base_bindir}/rarpd"
61FILES_${PN}-rdisc = "${base_bindir}/rdisc"