summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.8.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-05-18 12:57:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-20 22:52:22 +0100
commita221b0566e53b66f7fba85d9a8740e2e1b5429f6 (patch)
tree17b55838f3921dd3749788e24d0c9fb761964cf7 /meta/recipes-extended/iptables/iptables_1.8.7.bb
parent8d0e9d055a187ae9559ba2aceaad96ae790c8d71 (diff)
downloadpoky-a221b0566e53b66f7fba85d9a8740e2e1b5429f6.tar.gz
iptables: upgrade 1.8.7 -> 1.8.8
(From OE-Core rev: b44d6bc7e56121d977a7bc491aec00cf3fb510fb) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.8.7.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.8.7.bb116
1 files changed, 0 insertions, 116 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.8.7.bb b/meta/recipes-extended/iptables/iptables_1.8.7.bb
deleted file mode 100644
index 3b41882841..0000000000
--- a/meta/recipes-extended/iptables/iptables_1.8.7.bb
+++ /dev/null
@@ -1,116 +0,0 @@
1SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc \
9"
10
11SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
12 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
13 file://0001-Makefile.am-do-not-install-etc-ethertypes.patch \
14 file://0002-configure.ac-only-check-conntrack-when-libnfnetlink-enabled.patch \
15 file://iptables.service \
16 file://iptables.rules \
17 file://ip6tables.service \
18 file://ip6tables.rules \
19 "
20SRC_URI[sha256sum] = "c109c96bb04998cd44156622d36f8e04b140701ec60531a10668cfdff5e8d8f0"
21
22SYSTEMD_SERVICE:${PN} = "\
23 iptables.service \
24 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'ip6tables.service', '', d)} \
25"
26
27inherit autotools pkgconfig systemd
28
29EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR}"
30
31PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
32PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
33
34# libnfnetlink recipe is in meta-networking layer
35PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack"
36
37# libnftnl recipe is in meta-networking layer(previously known as libnftables)
38PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl"
39
40do_configure:prepend() {
41 # Remove some libtool m4 files
42 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
43 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
44}
45
46IPTABLES_RULES_DIR ?= "${sysconfdir}/${BPN}"
47
48do_install:append() {
49 install -d ${D}${IPTABLES_RULES_DIR}
50 install -m 0644 ${WORKDIR}/iptables.rules ${D}${IPTABLES_RULES_DIR}
51
52 install -d ${D}${systemd_system_unitdir}
53 install -m 0644 ${WORKDIR}/iptables.service ${D}${systemd_system_unitdir}
54
55 sed -i \
56 -e 's,@SBINDIR@,${sbindir},g' \
57 -e 's,@RULESDIR@,${IPTABLES_RULES_DIR},g' \
58 ${D}${systemd_system_unitdir}/iptables.service
59
60 if ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'true', 'false', d)} ; then
61 install -m 0644 ${WORKDIR}/ip6tables.rules ${D}${IPTABLES_RULES_DIR}
62 install -m 0644 ${WORKDIR}/ip6tables.service ${D}${systemd_system_unitdir}
63
64 sed -i \
65 -e 's,@SBINDIR@,${sbindir},g' \
66 -e 's,@RULESDIR@,${IPTABLES_RULES_DIR},g' \
67 ${D}${systemd_system_unitdir}/ip6tables.service
68 fi
69
70 # if libnftnl is included, make the iptables symlink point to the nft-based binary by default
71 if ${@bb.utils.contains('PACKAGECONFIG', 'libnftnl', 'true', 'false', d)} ; then
72 ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables
73 fi
74}
75
76PACKAGES =+ "${PN}-modules ${PN}-apply"
77PACKAGES_DYNAMIC += "^${PN}-module-.*"
78
79python populate_packages:prepend() {
80 modules = do_split_packages(d, '${libdir}/xtables', r'lib(.*)\.so$', '${PN}-module-%s', '${PN} module %s', extra_depends='')
81 if modules:
82 metapkg = d.getVar('PN') + '-modules'
83 d.appendVar('RDEPENDS:' + metapkg, ' ' + ' '.join(modules))
84}
85
86RDEPENDS:${PN} = "${PN}-module-xt-standard"
87RRECOMMENDS:${PN} = " \
88 ${PN}-modules \
89 kernel-module-x-tables \
90 kernel-module-ip-tables \
91 kernel-module-iptable-filter \
92 kernel-module-iptable-nat \
93 kernel-module-nf-defrag-ipv4 \
94 kernel-module-nf-conntrack \
95 kernel-module-nf-conntrack-ipv4 \
96 kernel-module-nf-nat \
97 kernel-module-ipt-masquerade \
98 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', '\
99 kernel-module-ip6table-filter \
100 kernel-module-ip6-tables \
101 ', '', d)} \
102"
103
104FILES:${PN} += "${datadir}/xtables"
105
106FILES:${PN}-apply = "${sbindir}/ip*-apply"
107RDEPENDS:${PN}-apply = "${PN} bash"
108
109# Include the symlinks as well in respective packages
110FILES:${PN}-module-xt-conntrack += "${libdir}/xtables/libxt_state.so"
111FILES:${PN}-module-xt-ct += "${libdir}/xtables/libxt_NOTRACK.so"
112
113ALLOW_EMPTY:${PN}-modules = "1"
114
115INSANE_SKIP:${PN}-module-xt-conntrack = "dev-so"
116INSANE_SKIP:${PN}-module-xt-ct = "dev-so"