summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/images/core-image-testcontroller.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-16 17:43:45 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-20 16:45:25 +0000
commit95f236f668f641224144a527279e368e98e2e6bf (patch)
tree33b9226229a885ded1029c30a21770f1001a83ab /meta/recipes-extended/images/core-image-testcontroller.bb
parent9ebd0a84e70294440445c8d2da382409f2dcadf9 (diff)
downloadpoky-95f236f668f641224144a527279e368e98e2e6bf.tar.gz
core-image-testmaster: Rename to core-image-testcontroller
Rename the image, the test controller class/code/module and the underlying image sentinel file to all match the controller terminology. (From OE-Core rev: f87b32833ac5327c4659ab8c06af34e7bda83f83) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/images/core-image-testcontroller.bb')
-rw-r--r--meta/recipes-extended/images/core-image-testcontroller.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-extended/images/core-image-testcontroller.bb b/meta/recipes-extended/images/core-image-testcontroller.bb
new file mode 100644
index 0000000000..20edbd5630
--- /dev/null
+++ b/meta/recipes-extended/images/core-image-testcontroller.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "A test controller image to be deployed on a target useful for testing other images using the OEQA runtime tests"
2
3IMAGE_FEATURES += "ssh-server-openssh package-management"
4
5inherit core-image
6
7# the deploy code requires bash and
8# normal linux utilities not busybox ones
9IMAGE_INSTALL += "\
10 bash coreutils util-linux tar gzip bzip2 kmod \
11 python3-modules python3-misc \
12 e2fsprogs e2fsprogs-mke2fs parted \
13 "
14# we need a particular initramfs for live images
15# that pulls custom install scripts which take
16# care of partitioning for us
17INITRD_IMAGE = "core-image-testcontroller-initramfs"
18