summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_3.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2021-08-17 13:39:27 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-18 17:01:06 +0100
commit33cb14f6a0dbaf81baf97d2b321474f6e8cbf1e1 (patch)
treeffa849945c8e08a80cb6c601160cf5d007540ab3 /meta/recipes-extended/grep/grep_3.6.bb
parent8fe33c72154984c7339dc2545d8d3cf4c0817822 (diff)
downloadpoky-33cb14f6a0dbaf81baf97d2b321474f6e8cbf1e1.tar.gz
grep: upgrade 3.6 -> 3.7
GNU grep 3.7 has been released with a fix for a bug causing "extreme performance degradation" in certain types of search. https://www.theregister.com/2021/08/16/gnu_grep_37/ (From OE-Core rev: 8a2bfc9da626597e915b774e1dca95ae2929014f) Signed-off-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_3.6.bb')
-rw-r--r--meta/recipes-extended/grep/grep_3.6.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/meta/recipes-extended/grep/grep_3.6.bb b/meta/recipes-extended/grep/grep_3.6.bb
deleted file mode 100644
index 750575ec22..0000000000
--- a/meta/recipes-extended/grep/grep_3.6.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3DESCRIPTION = "Grep searches one or more input files for lines containing a match to a specified pattern. By default, grep prints the matching lines."
4BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
5SECTION = "console/utils"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
8
9SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
10
11SRC_URI[sha256sum] = "667e15e8afe189e93f9f21a7cd3a7b3f776202f417330b248c2ad4f997d9373e"
12
13inherit autotools gettext texinfo pkgconfig
14
15# Fix "Argument list too long" error when len(TMPDIR) = 410
16acpaths = "-I ./m4"
17
18do_configure:prepend () {
19 sed -i -e '1s,#!@SHELL@,#!/bin/sh,' ${S}/src/egrep.sh
20 rm -f ${S}/m4/init.m4
21}
22
23do_install () {
24 autotools_do_install
25 if [ "${base_bindir}" != "${bindir}" ]; then
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
30 rmdir ${D}${bindir}/
31 fi
32}
33
34inherit update-alternatives
35
36PACKAGECONFIG ??= "pcre"
37PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre"
38
39ALTERNATIVE_PRIORITY = "100"
40
41ALTERNATIVE:${PN} = "grep egrep fgrep"
42ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
43ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
44ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
45
46BBCLASSEXTEND = "nativesdk"