summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_3.6.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-04 21:07:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-09 12:20:33 +0000
commit0cc5fc44c4f9d0a64e578f2ca393043d2c5d1656 (patch)
tree3bbc42029bf2f335b37afb6939da5e45c1f43eb7 /meta/recipes-extended/grep/grep_3.6.bb
parent612d17b7dad0b9fdfc701e2eb7f884fa0da53ba0 (diff)
downloadpoky-0cc5fc44c4f9d0a64e578f2ca393043d2c5d1656.tar.gz
grep: upgrade 3.5 -> 3.6
(From OE-Core rev: 98ed9f5fe421a41dcd661b32fe77a355d69d4dde) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_3.6.bb')
-rw-r--r--meta/recipes-extended/grep/grep_3.6.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_3.6.bb b/meta/recipes-extended/grep/grep_3.6.bb
new file mode 100644
index 0000000000..edf9b29c8f
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_3.6.bb
@@ -0,0 +1,43 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
9
10SRC_URI[sha256sum] = "667e15e8afe189e93f9f21a7cd3a7b3f776202f417330b248c2ad4f997d9373e"
11
12inherit autotools gettext texinfo pkgconfig
13
14# Fix "Argument list too long" error when len(TMPDIR) = 410
15acpaths = "-I ./m4"
16
17do_configure_prepend () {
18 sed -i -e '1s,#!@SHELL@,#!/bin/sh,' ${S}/src/egrep.sh
19 rm -f ${S}/m4/init.m4
20}
21
22do_install () {
23 autotools_do_install
24 if [ "${base_bindir}" != "${bindir}" ]; then
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
27 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
28 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
29 rmdir ${D}${bindir}/
30 fi
31}
32
33inherit update-alternatives
34
35PACKAGECONFIG ??= "pcre"
36PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre"
37
38ALTERNATIVE_PRIORITY = "100"
39
40ALTERNATIVE_${PN} = "grep egrep fgrep"
41ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
42ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
43ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"