summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_3.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-01-20 04:26:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:48:08 +0000
commita4fd8680fe6a1b700ff6ec4e034a212275492ae5 (patch)
treedde0e516b38dfbf3acb4f1e45eb5445e09372e10 /meta/recipes-extended/grep/grep_3.4.bb
parent6f902721c4e8d5e15dff9d8221f4d8db62425423 (diff)
downloadpoky-a4fd8680fe6a1b700ff6ec4e034a212275492ae5.tar.gz
grep: upgrade 3.3 -> 3.4
(From OE-Core rev: 4cf6ee13822f071e52c38658e26d4ffa0d37e4dc) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_3.4.bb')
-rw-r--r--meta/recipes-extended/grep/grep_3.4.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_3.4.bb b/meta/recipes-extended/grep/grep_3.4.bb
new file mode 100644
index 0000000000..fb8dcec490
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_3.4.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
9
10SRC_URI[md5sum] = "111b117d22d6a7d049d6ae7505e9c4d2"
11SRC_URI[sha256sum] = "58e6751c41a7c25bfc6e9363a41786cff3ba5709cf11d5ad903cf7cce31cc3fb"
12
13inherit autotools gettext texinfo pkgconfig
14
15# Fix "Argument list too long" error when len(TMPDIR) = 410
16acpaths = "-I ./m4"
17
18do_configure_prepend () {
19 rm -f ${S}/m4/init.m4
20}
21
22do_install () {
23 autotools_do_install
24 if [ "${base_bindir}" != "${bindir}" ]; then
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
27 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
28 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
29 rmdir ${D}${bindir}/
30 fi
31}
32
33inherit update-alternatives
34
35PACKAGECONFIG ??= "pcre"
36PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre"
37
38ALTERNATIVE_PRIORITY = "100"
39
40ALTERNATIVE_${PN} = "grep egrep fgrep"
41ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
42ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
43ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
44
45export CONFIG_SHELL="/bin/sh"