summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_3.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-18 17:49:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-19 16:14:57 +0000
commitcd24a399668414fb018622a8dd7a783418d7095d (patch)
tree9d5dd3cc0eecc1a4ce35999f4a06dd61ba8222c3 /meta/recipes-extended/grep/grep_3.3.bb
parent6a16017074f9829eaaa788767ce36df04bd3218c (diff)
downloadpoky-cd24a399668414fb018622a8dd7a783418d7095d.tar.gz
grep: upgrade 3.1 -> 3.3
License checksum changed due to cleanup, all URLs converted to https. need_charset_alias is no longer being used, drop the patch. (From OE-Core rev: 867a70ebbefcddae21f0668248fa22e2c4d3f849) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_3.3.bb')
-rw-r--r--meta/recipes-extended/grep/grep_3.3.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_3.3.bb b/meta/recipes-extended/grep/grep_3.3.bb
new file mode 100644
index 0000000000..704a3ecd06
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_3.3.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
9
10SRC_URI[md5sum] = "05d0718a1b7cc706a4bdf8115363f1ed"
11SRC_URI[sha256sum] = "b960541c499619efd6afe1fa795402e4733c8e11ebf9fafccc0bb4bccdc5b514"
12
13inherit autotools gettext texinfo pkgconfig
14
15# Fix "Argument list too long" error when len(TMPDIR) = 410
16acpaths = "-I ./m4"
17
18do_configure_prepend () {
19 rm -f ${S}/m4/init.m4
20}
21
22do_install () {
23 autotools_do_install
24 if [ "${base_bindir}" != "${bindir}" ]; then
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
27 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
28 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
29 rmdir ${D}${bindir}/
30 fi
31}
32
33inherit update-alternatives
34
35PACKAGECONFIG ??= "pcre"
36PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre"
37
38ALTERNATIVE_PRIORITY = "100"
39
40ALTERNATIVE_${PN} = "grep egrep fgrep"
41ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
42ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
43ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
44
45export CONFIG_SHELL="/bin/sh"