summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.5.1a.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-05-21 16:17:55 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-30 12:04:43 +0100
commit0b5c42347577425757afaf062f4d6aae4d27c7f7 (patch)
treef43cf742cf114c4a614234414ea35dc77ae5164c /meta/recipes-extended/grep/grep_2.5.1a.bb
parent2851d751a814bcf76f4032e8d3ff875a1012ba03 (diff)
downloadpoky-0b5c42347577425757afaf062f4d6aae4d27c7f7.tar.gz
grep: use new update-alternatives
(From OE-Core rev: ca478f563575ff2262741821ec35d4dfbf9f4487) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.5.1a.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.5.1a.bb23
1 files changed, 10 insertions, 13 deletions
diff --git a/meta/recipes-extended/grep/grep_2.5.1a.bb b/meta/recipes-extended/grep/grep_2.5.1a.bb
index 5aecf17cf0..3a8bcbfdb7 100644
--- a/meta/recipes-extended/grep/grep_2.5.1a.bb
+++ b/meta/recipes-extended/grep/grep_2.5.1a.bb
@@ -27,20 +27,17 @@ do_configure_prepend () {
27do_install () { 27do_install () {
28 autotools_do_install 28 autotools_do_install
29 install -d ${D}${base_bindir} 29 install -d ${D}${base_bindir}
30 mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN} 30 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
31 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN} 31 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
32 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN} 32 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
33 rmdir ${D}${bindir}/ 33 rmdir ${D}${bindir}/
34} 34}
35 35
36pkg_postinst_${PN} () { 36inherit update-alternatives
37 update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
38 update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
39 update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
40}
41 37
42pkg_prerm_${PN} () { 38ALTERNATIVE_PRIORITY = "100"
43 update-alternatives --remove grep grep.${PN} 39
44 update-alternatives --remove egrep egrep.${PN} 40ALTERNATIVE_${PN} = "grep egrep fgrep"
45 update-alternatives --remove fgrep fgrep.${PN} 41ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
46} 42ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
43ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"