summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.27.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-12-26 16:10:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-16 18:05:12 +0000
commit40cca1d0484e05ec20f638ff9160e4a84a76bf36 (patch)
treeb5d11979ed60dd35d13e8d6c95dc6f8e7c36d9bd /meta/recipes-extended/grep/grep_2.27.bb
parent382975e7b09c9443071e55b5b05be5e3d7ccd5f6 (diff)
downloadpoky-40cca1d0484e05ec20f638ff9160e4a84a76bf36.tar.gz
grep: upgrade to 2.27
(From OE-Core rev: 5cacc3cd986d5a6e7ed68171b3908fbae111330b) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.27.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.27.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.27.bb b/meta/recipes-extended/grep/grep_2.27.bb
new file mode 100644
index 0000000000..7d0a73bf06
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.27.bb
@@ -0,0 +1,43 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \
9 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
10 "
11
12SRC_URI[md5sum] = "6138dd227c39d4a25f81eea76a44d4cb"
13SRC_URI[sha256sum] = "ad4cc44d23074a1c3a8baae8fbafff2a8c60f38a9a6108f985eef6fbee6dcaeb"
14
15inherit autotools gettext texinfo
16
17EXTRA_OECONF = "--disable-perl-regexp"
18
19do_configure_prepend () {
20 rm -f ${S}/m4/init.m4
21}
22
23do_install () {
24 autotools_do_install
25 if [ "${base_bindir}" != "${bindir}" ]; then
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
30 rmdir ${D}${bindir}/
31 fi
32}
33
34inherit update-alternatives
35
36ALTERNATIVE_PRIORITY = "100"
37
38ALTERNATIVE_${PN} = "grep egrep fgrep"
39ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
40ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
41ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
42
43export CONFIG_SHELL="/bin/sh"