summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.21.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-26 17:35:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-27 22:53:39 +0000
commit16d74f8da855c3042ae6731a666501b56ad532fc (patch)
tree6be4964ef7281e395bf21d9ec1190d510f5bd3d7 /meta/recipes-extended/grep/grep_2.21.bb
parent088d4bb85cf7722723d2520585b74d3f7eddaafe (diff)
downloadpoky-16d74f8da855c3042ae6731a666501b56ad532fc.tar.gz
grep: upgrade to 2.21
(From OE-Core rev: f7a927a266ef08ea5c61b682e345a477a460d98b) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.21.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.21.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.21.bb b/meta/recipes-extended/grep/grep_2.21.bb
new file mode 100644
index 0000000000..2c378d8442
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.21.bb
@@ -0,0 +1,39 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
9
10SRC_URI[md5sum] = "43c48064d6409862b8a850db83c8038a"
11SRC_URI[sha256sum] = "5244a11c00dee8e7e5e714b9aaa053ac6cbfa27e104abee20d3c778e4bb0e5de"
12
13inherit autotools gettext texinfo
14
15EXTRA_OECONF = "--disable-perl-regexp"
16
17do_configure_prepend () {
18 rm -f ${S}/m4/init.m4
19}
20
21do_install () {
22 autotools_do_install
23 install -d ${D}${base_bindir}
24 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
25 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
26 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
27 rmdir ${D}${bindir}/
28}
29
30inherit update-alternatives
31
32ALTERNATIVE_PRIORITY = "100"
33
34ALTERNATIVE_${PN} = "grep egrep fgrep"
35ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
36ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
37ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
38
39export CONFIG_SHELL="/bin/sh"