summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.50.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-04-30 11:58:08 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-03 15:41:40 +0100
commita8a25ba59bb55d04f62d3eae8c3771f4f246e763 (patch)
tree891dcbb01c253b20ca90de2559bffd2206602c9a /meta/recipes-extended/ghostscript/ghostscript_9.50.bb
parent972b2705020debd1c35c29aa5690a57f79f25c38 (diff)
downloadpoky-a8a25ba59bb55d04f62d3eae8c3771f4f246e763.tar.gz
ghostscript: update 9.50 -> 9.52
Drop all custom objarch.h files; ghostscript nowadays generates that with autoconf. Freetype can no longer be disabled. Building out of source tree is broken. (From OE-Core rev: bb699a99b2e99a868520430c614d55ea3004427c) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.50.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.50.bb133
1 files changed, 0 insertions, 133 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.50.bb b/meta/recipes-extended/ghostscript/ghostscript_9.50.bb
deleted file mode 100644
index 5e8af8dc11..0000000000
--- a/meta/recipes-extended/ghostscript/ghostscript_9.50.bb
+++ /dev/null
@@ -1,133 +0,0 @@
1SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=70dc2bac4d0ce4448da873cd86b123fc"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
21
22def gs_verdir(v):
23 return "".join(v.split("."))
24
25
26SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${@gs_verdir("${PV}")}/${BPN}-${PV}.tar.gz \
27 file://ghostscript-9.15-parallel-make.patch \
28 file://ghostscript-9.16-Werror-return-type.patch \
29 file://do-not-check-local-libpng-source.patch \
30 file://avoid-host-contamination.patch \
31 file://mkdir-p.patch \
32 file://CVE-2019-14869-0001.patch \
33"
34
35SRC_URI = "${SRC_URI_BASE} \
36 file://ghostscript-9.21-prevent_recompiling.patch \
37 file://ghostscript-9.02-genarch.patch \
38 file://objarch.h \
39 file://cups-no-gcrypt.patch \
40 "
41
42SRC_URI_class-native = "${SRC_URI_BASE} \
43 file://ghostscript-9.21-native-fix-disable-system-libtiff.patch \
44 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
45 "
46
47SRC_URI[md5sum] = "00970cf622bd5b46f68eec9383753870"
48SRC_URI[sha256sum] = "0f53e89fd647815828fc5171613e860e8535b68f7afbc91bf89aee886769ce89"
49
50# Put something like
51#
52# PACKAGECONFIG_append_pn-ghostscript = " x11"
53#
54# in local.conf to enable building with X11. Be careful. The order
55# of the overrides matters!
56#
57#PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
58PACKAGECONFIG_class-native = ""
59
60PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
61 --without-x, virtual/libx11 libxext libxt gtk+3\
62 "
63
64EXTRA_OECONF = "--without-libpaper --with-system-libtiff --without-jbig2dec \
65 --with-fontpath=${datadir}/fonts \
66 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
67 --with-cups-datadir=${datadir}/cups \
68 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
69 "
70
71EXTRA_OECONF_append_mipsarcho32 = " --with-large_color_index=0"
72
73# Explicity disable libtiff, fontconfig,
74# freetype, cups for ghostscript-native
75EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
76 --without-jbig2dec --without-libpaper \
77 --with-fontpath=${datadir}/fonts \
78 --without-libidn --disable-fontconfig \
79 --disable-freetype --disable-cups"
80
81# This has been fixed upstream but for now we need to subvert the check for time.h
82# http://bugs.ghostscript.com/show_bug.cgi?id=692443
83# http://bugs.ghostscript.com/show_bug.cgi?id=692426
84CFLAGS += "-DHAVE_SYS_TIME_H=1"
85BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
86
87inherit autotools
88
89do_configure_prepend () {
90 mkdir -p obj
91 mkdir -p soobj
92 if [ -e ${WORKDIR}/objarch.h ]; then
93 cp ${WORKDIR}/objarch.h obj/arch.h
94 fi
95}
96
97do_configure_append () {
98 # copy tools from the native ghostscript build
99 if [ "${PN}" != "ghostscript-native" ]; then
100 mkdir -p obj/aux soobj
101 for i in genarch genconf mkromfs echogs gendev genht packps; do
102 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
103 done
104 fi
105}
106
107do_install_append () {
108 mkdir -p ${D}${datadir}/ghostscript/${PV}/
109 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
110 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
111}
112
113do_compile_class-native () {
114 mkdir -p obj
115 for i in genarch genconf mkromfs echogs gendev genht packps; do
116 oe_runmake obj/aux/$i
117 done
118}
119
120do_install_class-native () {
121 install -d ${D}${bindir}/ghostscript-${PV}
122 for i in genarch genconf mkromfs echogs gendev genht packps; do
123 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
124 done
125}
126
127BBCLASSEXTEND = "native"
128
129# ghostscript does not supports "arc"
130COMPATIBLE_HOST = "^(?!arc).*"
131
132# some entries in NVD uses gpl_ghostscript
133CVE_PRODUCT = "ghostscript gpl_ghostscript"