summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.02.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-05-20 17:26:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-25 15:50:54 +0100
commitc2d187065e81b1cef8fd6ce36dbe582866320c11 (patch)
tree3be665f386234bf5c04c905c43a2ce3652450180 /meta/recipes-extended/ghostscript/ghostscript_9.02.bb
parent98e8faa2f50773f6b91dc53c893c7e31afe47f57 (diff)
downloadpoky-c2d187065e81b1cef8fd6ce36dbe582866320c11.tar.gz
ghostscript: fix run failure on mpc8315e
When run gs on mpc8315, it fails with: GPL Ghostscript 9.02: ./psi/interp.c(291): Fatal error -20 in gs_interp_init! It is caused by cross compile. Accoding to the ghostscript document on: http://pages.cs.wisc.edu/~ghost/doc/cvs/Make.htm#Cross-compiling it needs some manual work, so import patches from WindRiver Linux. Update to using oe way to add arch.h, thanks to Richard. (From OE-Core rev: debee5134a2ca505e968a6ddfb5c2f6434e3007a) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.02.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.02.bb22
1 files changed, 19 insertions, 3 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.02.bb b/meta/recipes-extended/ghostscript/ghostscript_9.02.bb
index dcdedade10..e3d32ddab4 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.02.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.02.bb
@@ -15,22 +15,32 @@ SECTION = "console/utils"
15LICENSE = "GPLv3" 15LICENSE = "GPLv3"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24" 16LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24"
17 17
18PR = "r0" 18PR = "r1"
19 19
20DEPENDS = "tiff ${PN}-native" 20DEPENDS = "${PN}-native tiff jpeg fontconfig cups"
21DEPENDS_virtclass-native = "" 21DEPENDS_virtclass-native = ""
22 22
23SRC_URI = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.bz2 \ 23SRC_URI = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.bz2 \
24 file://ghostscript-9.02-prevent_recompiling.patch \ 24 file://ghostscript-9.02-prevent_recompiling.patch \
25 file://ghostscript-9.02-genarch.patch \
26 file://objarch.h \
27 file://soobjarch.h \
25 " 28 "
26 29
27SRC_URI[md5sum] = "f67151444bd56a7904579fc75a083dd6" 30SRC_URI[md5sum] = "f67151444bd56a7904579fc75a083dd6"
28SRC_URI[sha256sum] = "03ea2cad13a36f8f9160912012b79619a826e7148fada6d3531feb25409ee05a" 31SRC_URI[sha256sum] = "03ea2cad13a36f8f9160912012b79619a826e7148fada6d3531feb25409ee05a"
29 32
30EXTRA_OECONF = "--with-system-libtiff --without-jbig2dec --without-jasper --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib" 33EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec --without-jasper --with-fontpath=${datadir}/fonts"
31 34
32inherit autotools 35inherit autotools
33 36
37do_configure_prepend () {
38 mkdir -p obj
39 mkdir -p soobj
40 cp ${WORKDIR}/objarch.h obj/arch.h
41 cp ${WORKDIR}/soobjarch.h soobj/arch.h
42}
43
34do_configure () { 44do_configure () {
35 oe_runconf 45 oe_runconf
36 46
@@ -42,6 +52,12 @@ do_configure () {
42 done 52 done
43} 53}
44 54
55do_install_append () {
56 mkdir -p ${D}${datadir}/ghostscript/${PV}/
57 cp -r Resource ${D}${datadir}/ghostscript/${PV}/
58 cp -r iccprofiles ${D}${datadir}/ghostscript/${PV}/
59}
60
45python do_patch_virtclass-native () { 61python do_patch_virtclass-native () {
46 pass 62 pass
47} 63}