summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk/gawk_4.1.3.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-06-01 17:44:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-03 16:38:46 +0100
commit9ee388fc06220c95650b938d7687f9485cb51137 (patch)
treee29c68185f25ed6897547f3869e718a8cbd7d2e9 /meta/recipes-extended/gawk/gawk_4.1.3.bb
parented3283b7474739b4348ff76c55d47b0f1fd2724d (diff)
downloadpoky-9ee388fc06220c95650b938d7687f9485cb51137.tar.gz
gawk: upgrade to 4.1.3
The following two patches are removed because they have been merged in the new version. Use-DESTDIR-in-extension-Makefile.am-when-removing-..patch extension-Add-DESTDIR-prefix-to-remaining-pkgextensi.patch (From OE-Core rev: 491d485ade68c128624eee00977f293dba8f64b9) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/gawk/gawk_4.1.3.bb')
-rw-r--r--meta/recipes-extended/gawk/gawk_4.1.3.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_4.1.3.bb b/meta/recipes-extended/gawk/gawk_4.1.3.bb
new file mode 100644
index 0000000000..d1a88e45a9
--- /dev/null
+++ b/meta/recipes-extended/gawk/gawk_4.1.3.bb
@@ -0,0 +1,47 @@
1SUMMARY = "GNU awk text processing utility"
2DESCRIPTION = "The GNU version of awk, a text processing utility. \
3Awk interprets a special-purpose programming language to do \
4quick and easy text pattern matching and reformatting jobs."
5HOMEPAGE = "https://www.gnu.org/software/gawk/"
6BUGTRACKER = "bug-gawk@gnu.org"
7SECTION = "console/utils"
8
9# gawk <= 3.1.5: GPLv2
10# gawk >= 3.1.6: GPLv3
11LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14DEPENDS += "readline"
15
16PACKAGECONFIG[mpfr] = "--with-mpfr,--without-mpfr, mpfr"
17
18SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
19 file://run-ptest \
20"
21
22SRC_URI[md5sum] = "55d37f4069502677f25d1340df8eec97"
23SRC_URI[sha256sum] = "524effa5b9ecd4ed940f2581c5d3c1df4e4bd7e6f768aa033c1916f47dfc6e29"
24
25inherit autotools gettext texinfo update-alternatives
26
27FILES_${PN} += "${datadir}/awk"
28FILES_${PN}-dev += "${libdir}/${BPN}/*.la"
29FILES_${PN}-dbg += "${libexecdir}/awk/.debug"
30
31ALTERNATIVE_${PN} = "awk"
32ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
33ALTERNATIVE_PRIORITY = "100"
34
35do_install_append() {
36 # remove the link since we don't package it
37 rm ${D}${bindir}/awk
38}
39
40inherit ptest
41
42do_install_ptest() {
43 mkdir ${D}${PTEST_PATH}/test
44 for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests; \
45 do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
46 done
47}