summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_6.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-09-22 09:24:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-26 10:35:27 +0100
commitd502aea544fb555c5db7674b1db38d725b9fac1c (patch)
treeefed3460be3efe1b39e10acb642474cda0374aed /meta/recipes-extended/ethtool/ethtool_6.5.bb
parentb630120a0b34e0e4b0803361b6d4c317cdfa33a0 (diff)
downloadpoky-d502aea544fb555c5db7674b1db38d725b9fac1c.tar.gz
ethtool: upgrade 6.3 -> 6.5
(From OE-Core rev: 282785a4674638fac7f00ce38cf5beef1e35c2fc) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_6.5.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_6.5.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_6.5.bb b/meta/recipes-extended/ethtool/ethtool_6.5.bb
new file mode 100644
index 0000000000..ef925e16b9
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_6.5.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[sha256sum] = "aed41ca58b3129126f18429172064d214191d7e7ef52c6e3f6b2ff7503706c03"
15
16UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
17
18inherit autotools ptest bash-completion pkgconfig
19
20RDEPENDS:${PN}-ptest += "make bash"
21
22PACKAGECONFIG ?= "netlink"
23PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
24
25do_compile_ptest() {
26 oe_runmake buildtest-TESTS
27}
28
29do_install_ptest () {
30 cp ${B}/Makefile ${D}${PTEST_PATH}
31 install ${B}/test-cmdline ${D}${PTEST_PATH}
32 if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
33 install ${B}/test-features ${D}${PTEST_PATH}
34 fi
35 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
36 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
37}