summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_6.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-03-09 16:19:40 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-11 00:08:40 +0000
commit356c9931303917e82f162bb13ad317174edb047b (patch)
treeca9d1fa81640321a12cf3092a4b0ec562b96bc49 /meta/recipes-extended/ethtool/ethtool_6.2.bb
parent82fd20bf43e384a855e259fcc6ad598a13a702df (diff)
downloadpoky-356c9931303917e82f162bb13ad317174edb047b.tar.gz
ethtool: update 6.1 -> 6.2
Drop patch merged upstream. (From OE-Core rev: ae0e692476b9564aa0a64f65d2abfdc0e55ef23b) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_6.2.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_6.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_6.2.bb b/meta/recipes-extended/ethtool/ethtool_6.2.bb
new file mode 100644
index 0000000000..881e638851
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_6.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[sha256sum] = "1a9f95c3d8c1795a942220912d72c06a208f1c122a78f7690259402856ff06a0"
15
16UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
17
18inherit autotools ptest bash-completion pkgconfig
19
20RDEPENDS:${PN}-ptest += "make"
21
22PACKAGECONFIG ?= "netlink"
23PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
24
25do_compile_ptest() {
26 oe_runmake buildtest-TESTS
27}
28
29do_install_ptest () {
30 cp ${B}/Makefile ${D}${PTEST_PATH}
31 install ${B}/test-cmdline ${D}${PTEST_PATH}
32 if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
33 install ${B}/test-features ${D}${PTEST_PATH}
34 fi
35 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
36 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
37}