summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_5.19.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-08-30 12:09:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-01 10:14:01 +0100
commit1fc763114765727aa2c378ce1edd0577b37d1308 (patch)
treee8ce18d6105b4f298a707f30b1fb5ca213f19080 /meta/recipes-extended/ethtool/ethtool_5.19.bb
parent8d6b8fb0863d81f60f8a8b53c3b5b4676d508965 (diff)
downloadpoky-1fc763114765727aa2c378ce1edd0577b37d1308.tar.gz
ethtool: upgrade 5.18 -> 5.19
avoid_parallel_tests.patch refreshed for new version. (From OE-Core rev: 4acfd197198ab0b94fffefe25e6b4df210477751) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_5.19.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_5.19.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_5.19.bb b/meta/recipes-extended/ethtool/ethtool_5.19.bb
new file mode 100644
index 0000000000..8c995b21e1
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_5.19.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[sha256sum] = "24412dcd4ac886177abd68282efa98914a4dd2497218e298e7049e9cb72b2336"
15
16UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
17
18inherit autotools ptest bash-completion pkgconfig
19
20RDEPENDS:${PN}-ptest += "make"
21
22PACKAGECONFIG ?= "netlink"
23PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
24
25do_compile_ptest() {
26 oe_runmake buildtest-TESTS
27}
28
29do_install_ptest () {
30 cp ${B}/Makefile ${D}${PTEST_PATH}
31 install ${B}/test-cmdline ${D}${PTEST_PATH}
32 if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
33 install ${B}/test-features ${D}${PTEST_PATH}
34 fi
35 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
36 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
37}