summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_5.10.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-26 10:26:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-30 14:01:06 +0000
commit9ca51c8241883f0082d62e4aaa1278915d4d2912 (patch)
tree6e1bf7698f1c7f18ab7ec8f6f15b724edb4c15e7 /meta/recipes-extended/ethtool/ethtool_5.10.bb
parent8ff9bbd64f430e4f9c77a4c8606a919bc8ece000 (diff)
downloadpoky-9ca51c8241883f0082d62e4aaa1278915d4d2912.tar.gz
ethtool: upgrade 5.9 -> 5.10
(From OE-Core rev: 2a65abeee1888108c2cbcc989f2774fe9ce28366) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_5.10.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_5.10.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_5.10.bb b/meta/recipes-extended/ethtool/ethtool_5.10.bb
new file mode 100644
index 0000000000..5c0df3acbc
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_5.10.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[sha256sum] = "4b86adb3ed913c1ef14a276301981f696ab4ec360c19f0a5b68235c4756abae5"
15
16UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
17
18inherit autotools ptest bash-completion pkgconfig
19
20RDEPENDS_${PN}-ptest += "make"
21
22PACKAGECONFIG ?= "netlink"
23PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
24
25do_compile_ptest() {
26 oe_runmake buildtest-TESTS
27}
28
29do_install_ptest () {
30 cp ${B}/Makefile ${D}${PTEST_PATH}
31 install ${B}/test-cmdline ${D}${PTEST_PATH}
32 if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
33 install ${B}/test-features ${D}${PTEST_PATH}
34 fi
35 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
36 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
37}