summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.8.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-10-23 14:29:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:35 +0000
commite7db31e5c47bf3e77e0353da59dbcd86b053bbce (patch)
tree4a1eace2bfdb863038c94bd38948d467af75930c /meta/recipes-extended/ethtool/ethtool_4.8.bb
parent9d60b5de84068d560aeb7698368c67f66970181a (diff)
downloadpoky-e7db31e5c47bf3e77e0353da59dbcd86b053bbce.tar.gz
ethtool: Upgrade 4.6 -> 4.8
Various bug fixes and improvements. (From OE-Core rev: 1aa70f441e6cda540699b65a45c0ad71eff5e17c) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.8.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.8.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.8.bb b/meta/recipes-extended/ethtool/ethtool_4.8.bb
new file mode 100644
index 0000000000..4ca88d766c
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.8.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "28c4a4d85c33f573c49ff6d81ec094fd"
15SRC_URI[sha256sum] = "1bd82ebe3d41de1b7b0d8f4fb18a8e8466fba934c952bc5c5002836ffa8bb606"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make"
19
20do_compile_ptest() {
21 oe_runmake buildtest-TESTS
22}
23
24do_install_ptest () {
25 cp ${B}/Makefile ${D}${PTEST_PATH}
26 install ${B}/test-cmdline ${D}${PTEST_PATH}
27 install ${B}/test-features ${D}${PTEST_PATH}
28 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
29 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
30}