summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.19.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2018-11-22 01:48:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-08 20:14:42 +0000
commitb4e664db713cf37010e86205ebf6d969bcb5fa80 (patch)
treee6917cc5c33acdcfbbc8a2f2b47b66bc2037515d /meta/recipes-extended/ethtool/ethtool_4.19.bb
parent34a2953a95413fefd5a5f9fa25eaeb5fb5e02b03 (diff)
downloadpoky-b4e664db713cf37010e86205ebf6d969bcb5fa80.tar.gz
ethtool: 4.17 -> 4.19
(From OE-Core rev: 565bbbf43da14de466fccdfaa259bdb9b50b686e) (From OE-Core rev: 4bcacd05428498158ae2fedc11bf4d6f11824967) Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.19.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.19.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.19.bb b/meta/recipes-extended/ethtool/ethtool_4.19.bb
new file mode 100644
index 0000000000..74e255c24b
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.19.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "a533db1d202724822c4ef297643fac12"
15SRC_URI[sha256sum] = "e8e88f5a79c78e542cd84fee60b67dbf29cee63e4760e8d61544fea74c761ad1"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make"
19
20do_compile_ptest() {
21 oe_runmake buildtest-TESTS
22}
23
24do_install_ptest () {
25 cp ${B}/Makefile ${D}${PTEST_PATH}
26 install ${B}/test-cmdline ${D}${PTEST_PATH}
27 install ${B}/test-features ${D}${PTEST_PATH}
28 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
29 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
30}