summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.11.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-07-13 06:45:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-17 14:01:39 +0100
commitfb449921ac40c267b4e6a80f7b242cf749b0d218 (patch)
tree69e0bcd6e6c46980b62279cb6aec87e4432367ce /meta/recipes-extended/ethtool/ethtool_4.11.bb
parent1d7fab4b0fcfffa27473d5b9ca288cc917d35301 (diff)
downloadpoky-fb449921ac40c267b4e6a80f7b242cf749b0d218.tar.gz
ethtool: Upgrade to 4.11
Restore SRC_URI address (From OE-Core rev: 79212fea2ad6bf61097a8e1cda2e17ea30d059cb) Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.11.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.11.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.11.bb b/meta/recipes-extended/ethtool/ethtool_4.11.bb
new file mode 100644
index 0000000000..befe9b939a
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.11.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "8f1072679888c9335e49b17efb798b4c"
15SRC_URI[sha256sum] = "af2fd9692f3159d3ab1e41e6f9b7d8db2a4693f1cb22348c88ba89f70f0e6503"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make"
19
20do_compile_ptest() {
21 oe_runmake buildtest-TESTS
22}
23
24do_install_ptest () {
25 cp ${B}/Makefile ${D}${PTEST_PATH}
26 install ${B}/test-cmdline ${D}${PTEST_PATH}
27 install ${B}/test-features ${D}${PTEST_PATH}
28 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
29 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
30}