summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-12-28 22:19:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-07 11:09:42 +0000
commiteb91689e33c0e2798dcb8c027d9c1e2bf5450cf7 (patch)
treedb002db246830b6a4daad85f809fd930ffdb48c8 /meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
parent6c7ab511ca4e89be721f54bb45b6ef46d4bb9944 (diff)
downloadpoky-eb91689e33c0e2798dcb8c027d9c1e2bf5450cf7.tar.gz
chkconfig: package the update-alternatives implementation
(From OE-Core rev: c18b1ce2d98460e5ee6ec6319071bc1fa1016ede) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb26
1 files changed, 22 insertions, 4 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
index df9b193ac2..4c6985fd39 100644
--- a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
+++ b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
@@ -1,5 +1,4 @@
1SUMMARY = "A system tool for maintaining the /etc/rc*.d hierarchy" 1SUMMARY = "A system tool for maintaining the /etc/rc*.d hierarchy"
2
3DESCRIPTION = "Chkconfig is a basic system utility. It updates and queries runlevel \ 2DESCRIPTION = "Chkconfig is a basic system utility. It updates and queries runlevel \
4information for system services. Chkconfig manipulates the numerous \ 3information for system services. Chkconfig manipulates the numerous \
5symbolic links in /etc/rc.d, to relieve system administrators of some \ 4symbolic links in /etc/rc.d, to relieve system administrators of some \
@@ -11,8 +10,9 @@ LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018" 10LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
12 11
13DEPENDS = "libnewt popt" 12DEPENDS = "libnewt popt"
13PROVIDES += "virtual/update-alternatives"
14 14
15PR = "r6" 15PR = "r7"
16 16
17SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2" 17SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
18 18
@@ -29,18 +29,22 @@ EXTRA_OEMAKE = "\
29 'BINDIR=${base_sbindir}' \ 29 'BINDIR=${base_sbindir}' \
30 'SBINDIR=${sbindir}' \ 30 'SBINDIR=${sbindir}' \
31 'MANDIR=${mandir}' \ 31 'MANDIR=${mandir}' \
32 'ALTDIR=${localstatedir}/lib/alternatives' \
33 'ALTDATADIR=${sysconfdir}/alternatives' \
32" 34"
33 35
34do_unpack[postfuncs] += "obey_variables" 36do_unpack[postfuncs] += "obey_variables"
35do_unpack[vardeps] += "obey_variables" 37do_unpack[vardeps] += "obey_variables"
36obey_variables () { 38obey_variables () {
37 sed -i -e 's,/etc,${sysconfdir},; s,/lib/systemd,${base_libdir}/systemd,' leveldb.h 39 sed -i -e 's,/etc,${sysconfdir},; s,/lib/systemd,${base_libdir}/systemd,' leveldb.h
40 sed -i -e 's,/etc/alternatives,${sysconfdir}/alternatives,' \
41 -e 's,/var/lib/alternatives,${localstatedir}/lib/alternatives,' \
42 -e 's,/usr/share/locale,${datadir}/locale,' alternatives.c
38} 43}
39 44
40do_install() { 45do_install() {
41 oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' install 46 oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' install
42 mkdir -p ${D}${sysconfdir}/chkconfig.d 47 install -d ${D}${sysconfdir}/chkconfig.d
43 rm -f ${D}${sbindir}/update-alternatives
44} 48}
45 49
46do_install_append_linuxstdbase() { 50do_install_append_linuxstdbase() {
@@ -49,4 +53,18 @@ do_install_append_linuxstdbase() {
49 ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd 53 ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd
50} 54}
51 55
56PACKAGES =+ "${PN}-alternatives ${PN}-alternatives-doc"
57SUMMARY_${PN}-alternatives = "Maintain symbolic links determining default commands"
58DESCRIPTION_${PN}-alternatives = "alternatives creates, removes, maintains and displays \
59information about the symbolic links comprising the alternatives system."
60SUMMARY_${PN}-alternatives-doc = "${SUMMARY_${PN}-alternatives} - Documentation files"
61DESCRIPTION_${PN}-alternatives-doc = "${DESCRIPTION_${PN}-alternatives} \
62This package contains documentation."
63RPROVIDES_${PN}-alternatives += "update-alternatives"
64RCONFLICTS_${PN}-alternatives = "update-alternatives-cworth update-alternatives-dpkg"
65FILES_${PN}-alternatives = "${sbindir}/alternatives ${sbindir}/update-alternatives \
66 ${sysconfdir}/alternatives ${localstatedir}/lib/alternatives"
67FILES_${PN}-alternatives-doc = "${mandir}/man8/alternatives.8 \
68 ${mandir}/man8/update-alternatives.8"
69
52FILES_${PN}_append_linuxstdbase += "${libdir}/lsb" 70FILES_${PN}_append_linuxstdbase += "${libdir}/lsb"