summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-02-07 20:45:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-08 13:20:02 +0000
commit0e48ca10aa44c118ff1f97bf0394c04819c6dea4 (patch)
treeed97fb480f15f67847bad57e40a4110bf8601a60 /meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
parent9afefb02b0f46e54fd102383e8cd344dc54d2771 (diff)
downloadpoky-0e48ca10aa44c118ff1f97bf0394c04819c6dea4.tar.gz
chkconfig: remove the recipe
chkconfig is one of the options for virtual/update-alternatives, however opkg-utils have been used as the default for a very long time, while chkconfig isn't anymore tested in any way, and is stuck at a very old version due to newer versions requiring selinux. [YOCTO #11264] (From OE-Core rev: 61efc1e287326f52810a439ccde996f45ef89733) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
deleted file mode 100644
index d21dd69704..0000000000
--- a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1SUMMARY = "A system tool for maintaining the /etc/rc*.d hierarchy"
2DESCRIPTION = "Chkconfig is a basic system utility. It updates and queries runlevel \
3information for system services. Chkconfig manipulates the numerous \
4symbolic links in /etc/rc.d, to relieve system administrators of some \
5of the drudgery of manually editing the symbolic links."
6
7RECIPE_NO_UPDATE_REASON = "Version 1.5 requires selinux"
8
9HOMEPAGE = "https://github.com/fedora-sysv"
10
11LICENSE = "GPLv2"
12LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
13
14DEPENDS = "libnewt popt"
15PROVIDES += "virtual/update-alternatives"
16
17PR = "r7"
18
19S = "${WORKDIR}/${BPN}-${BPN}-${PV}"
20
21SRC_URI = "git://github.com/fedora-sysv/chkconfig.git \
22 file://replace_caddr_t.patch \
23 "
24
25SRCREV = "3e0b3909ff6328d232b27b9c32f1a9309c6cd0a4"
26UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
27
28S = "${WORKDIR}/git"
29
30inherit gettext
31
32# Makefile uses RPM_OPT_FLAGS to construct CFLAGS
33#
34EXTRA_OEMAKE = "\
35 'RPM_OPT_FLAGS=${CFLAGS}' \
36 'LDFLAGS=${LDFLAGS}' \
37 'BINDIR=${base_sbindir}' \
38 'SBINDIR=${sbindir}' \
39 'MANDIR=${mandir}' \
40 'ALTDIR=${localstatedir}/lib/alternatives' \
41 'ALTDATADIR=${sysconfdir}/alternatives' \
42"
43
44do_unpack[postfuncs] += "obey_variables"
45do_unpack[vardeps] += "obey_variables"
46obey_variables () {
47 sed -i -e 's,/etc,${sysconfdir},; s,/lib/systemd,${base_libdir}/systemd,' ${S}/leveldb.h
48 sed -i -e 's,/etc/alternatives,${sysconfdir}/alternatives,' \
49 -e 's,/var/lib/alternatives,${localstatedir}/lib/alternatives,' \
50 -e 's,/usr/share/locale,${datadir}/locale,' ${S}/alternatives.c
51}
52
53do_install() {
54 oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' \
55 'BINDIR=${sbindir}' install
56 install -d ${D}${sysconfdir}/chkconfig.d
57}
58
59PACKAGES =+ "${PN}-alternatives ${PN}-alternatives-doc"
60SUMMARY_${PN}-alternatives = "Maintain symbolic links determining default commands"
61DESCRIPTION_${PN}-alternatives = "alternatives creates, removes, maintains and displays \
62information about the symbolic links comprising the alternatives system."
63SUMMARY_${PN}-alternatives-doc = "${SUMMARY_${PN}-alternatives} - Documentation files"
64DESCRIPTION_${PN}-alternatives-doc = "${DESCRIPTION_${PN}-alternatives} \
65This package contains documentation."
66RPROVIDES_${PN}-alternatives += "update-alternatives"
67RCONFLICTS_${PN}-alternatives = "update-alternatives-opkg update-alternatives-dpkg"
68FILES_${PN}-alternatives = "${sbindir}/alternatives ${sbindir}/update-alternatives \
69 ${sysconfdir}/alternatives ${localstatedir}/lib/alternatives"
70FILES_${PN}-alternatives-doc = "${mandir}/man8/alternatives.8 \
71 ${mandir}/man8/update-alternatives.8"