summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-07-18 10:16:04 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-19 08:41:40 +0100
commit71eb7d07dac5d7c1b4a841785ea671f87b54a087 (patch)
treef9ec43033da1a333dbedf234810b5d5d31aa608d /meta/recipes-extended/bzip2/bzip2_1.0.8.bb
parent58d3ca6c159c784ce5d57a95f2c9c060940a5da5 (diff)
downloadpoky-71eb7d07dac5d7c1b4a841785ea671f87b54a087.tar.gz
bzip2: upgrade 1.0.7 -> 1.0.8
License-Update: Change in version and copyright year/date. Changelog: https://sourceware.org/git/?p=bzip2.git;a=blob;f=CHANGES (From OE-Core rev: ad33d889ad551651d72cf1cdfdfffdd147ee91ac) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.8.bb')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.8.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.8.bb b/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
new file mode 100644
index 0000000000..73d933a002
--- /dev/null
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
5HOMEPAGE = "https://sourceware.org/bzip2/"
6SECTION = "console/utils"
7LICENSE = "bzip2"
8LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664"
9
10SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \
11 file://configure.ac;subdir=${BP} \
12 file://Makefile.am;subdir=${BP} \
13 file://run-ptest \
14 "
15SRC_URI[md5sum] = "67e051268d0c475ea773822f7500d0e5"
16SRC_URI[sha256sum] = "ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269"
17
18UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/"
19UPSTREAM_VERSION_UNKNOWN = "1"
20
21PACKAGES =+ "libbz2"
22
23CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
24
25inherit autotools update-alternatives ptest relative_symlinks
26
27ALTERNATIVE_PRIORITY = "100"
28ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2"
29
30#install binaries to bzip2-native under sysroot for replacement-native
31EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
32
33do_install_ptest () {
34 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
35}
36
37FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
38
39RDEPENDS_${PN}-ptest += "make"
40
41PROVIDES_append_class-native = " bzip2-replacement-native"
42BBCLASSEXTEND = "native nativesdk"