summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2-1.0.5/Makefile.am
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-11-03 15:06:24 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-10 21:09:22 +0800
commita0fb0c209056a958a5d775cc9efee57875a6234a (patch)
tree12adf55b69370d9f3d71ddf1f0f331cf027c90bd /meta/recipes-extended/bzip2/bzip2-1.0.5/Makefile.am
parent12a861359a3413ded52174c814e8653c56caee17 (diff)
downloadpoky-a0fb0c209056a958a5d775cc9efee57875a6234a.tar.gz
bzip2: upgrade to version 1.0.6
resolves security bug CVE-2010-0405 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2-1.0.5/Makefile.am')
-rw-r--r--meta/recipes-extended/bzip2/bzip2-1.0.5/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2-1.0.5/Makefile.am b/meta/recipes-extended/bzip2/bzip2-1.0.5/Makefile.am
deleted file mode 100644
index 070d57b243..0000000000
--- a/meta/recipes-extended/bzip2/bzip2-1.0.5/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
1
2lib_LTLIBRARIES = libbz2.la
3
4libbz2_la_SOURCES = blocksort.c \
5 huffman.c \
6 crctable.c \
7 randtable.c \
8 compress.c \
9 decompress.c \
10 bzlib.c
11
12bin_PROGRAMS = bzip2 bzip2recover
13
14bzip2_SOURCES = bzip2.c
15bzip2_LDADD = libbz2.la
16bzip2_DEPENDENCIES = libbz2.la
17
18include_HEADERS = bzlib.h
19
20bzip2recover_SOURCES = bzip2recover.c
21bzip2recover_LDADD = libbz2.la
22bzip2recover_DEPENDENCIES = libbz2.la
23
24bin_SCRIPTS = bzgrep bzmore bzdiff
25
26man_MANS = bzip2.1 bzgrep.1 bzmore.1 bzdiff.1
27EXTRA_DIST = $(man_MANS)
28
29install-exec-hook:
30 ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bunzip2$(EXEEXT)
31 ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bzcat$(EXEEXT)
32 ln -s $(bindir)/bzgrep$(EXEEXT) $(DESTDIR)$(bindir)/bzegrep$(EXEEXT)
33 ln -s $(bindir)/bzgrep$(EXEEXT) $(DESTDIR)$(bindir)/bzfgrep$(EXEEXT)
34 ln -s $(bindir)/bzmore$(EXEEXT) $(DESTDIR)$(bindir)/bzless$(EXEEXT)
35 ln -s $(bindir)/bzdiff$(EXEEXT) $(DESTDIR)$(bindir)/bzcmp$(EXEEXT)
36
37install-data-hook:
38 echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzegrep.1
39 echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzfgrep.1
40 echo ".so man1/bzmore.1" > $(DESTDIR)$(mandir)/man1/bzless.1
41 echo ".so man1/bzdiff.1" > $(DESTDIR)$(mandir)/man1/bzcmp.1