summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.1.13.bb
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2013-10-24 11:01:48 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-30 13:39:09 +0000
commit7330735ae29c4570a73f723ba437a2c422c04921 (patch)
tree3c73aed03506746e78ee08ed0cfc3c03f30ef636 /meta/recipes-extended/at/at_3.1.13.bb
parent44e2ea50218a8c79fb3bec02d9c0bcd25f874bc0 (diff)
downloadpoky-7330735ae29c4570a73f723ba437a2c422c04921.tar.gz
at: upgrade to 3.1.14
Removed 2 patches because they were merged upstream (From OE-Core rev: ff1707449d851a365e686e6d2cbe822631001147) Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.13.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.13.bb66
1 files changed, 0 insertions, 66 deletions
diff --git a/meta/recipes-extended/at/at_3.1.13.bb b/meta/recipes-extended/at/at_3.1.13.bb
deleted file mode 100644
index 6fa13b91fb..0000000000
--- a/meta/recipes-extended/at/at_3.1.13.bb
+++ /dev/null
@@ -1,66 +0,0 @@
1SUMMARY = "Delayed job execution and batch processing"
2DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \
3the system load levels drop to a particular level."
4SECTION = "base"
5LICENSE="GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
7DEPENDS = "flex flex-native \
8 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
9
10VIRTUAL-RUNTIME_initscripts ?= "initscripts"
11RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \
12 ${VIRTUAL-RUNTIME_initscripts} \
13"
14
15PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
16
17RCONFLICTS_${PN} = "atd"
18RREPLACES_${PN} = "atd"
19PR = "r5"
20
21SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
22 file://configure.patch \
23 file://use-ldflags.patch \
24 file://fix_parallel_build_error.patch \
25 file://posixtm.c \
26 file://posixtm.h \
27 file://file_replacement_with_gplv2.patch \
28 file://S99at \
29 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
30
31PAM_SRC_URI = "file://pam.conf.patch \
32 file://configure-add-enable-pam.patch"
33
34SRC_URI[md5sum] = "1da61af6c29e323abaaf13ee1a8dad79"
35SRC_URI[sha256sum] = "3a8b90868d615d21a92f4986ea9a823886329af8fae8dd7ab4eed9b273bca072"
36
37EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
38 --with-daemon_username=root \
39 --with-daemon_groupname=root \
40 --with-jobdir=/var/spool/at/jobs \
41 --with-atspool=/var/spool/at/spool \
42 ac_cv_header_security_pam_appl_h=${@base_contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} "
43
44inherit autotools
45
46PARALLEL_MAKE = ""
47
48do_compile_prepend () {
49 cp -f ${WORKDIR}/posixtm.[ch] ${S}
50}
51
52do_install () {
53 oe_runmake -e "IROOT=${D}" install
54
55 install -d ${D}${sysconfdir}/init.d
56 install -d ${D}${sysconfdir}/rcS.d
57 install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/atd
58 ln -sf ../init.d/atd ${D}${sysconfdir}/rcS.d/S99at
59
60 for feature in ${DISTRO_FEATURES}; do
61 if [ "$feature" = "pam" ]; then
62 install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd
63 break
64 fi
65 done
66}