summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-10-28 17:41:18 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:34 +0000
commit6c6b6753c0d3494fa79ae493d5d798495a9b03ba (patch)
treeb1ab7d4095d01053d7ef6f42493d8653e1ad04c3 /meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
parent0340573629b5faab18859e731a91876d0798186a (diff)
downloadpoky-6c6b6753c0d3494fa79ae493d5d798495a9b03ba.tar.gz
valgrind: update to 3.12.0
Remove backported gcc5-port.patch Remove 11_mips-link-tool.patch as there is nothing in the target file (or the entire source tree) that resembles anything contained in the patch. (From OE-Core rev: 221093e850fbc3c154e9069f1958384b59ba3f70) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.11.0.bb')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.11.0.bb123
1 files changed, 0 insertions, 123 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
deleted file mode 100644
index 42fd27f537..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
+++ /dev/null
@@ -1,123 +0,0 @@
1SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=1;endline=29;md5=ebb8e640ef633f940c425686c873f9fa \
7 file://include/valgrind.h;beginline=1;endline=56;md5=4b5e24908e53016ea561c45f4234a327 \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
19 file://11_mips-link-tool.patch \
20 file://0002-remove-rpath.patch \
21 file://0004-Fix-out-of-tree-builds.patch \
22 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
23 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
24 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
25 file://avoid-neon-for-targets-which-don-t-support-it.patch \
26 file://gcc5-port.patch \
27"
28SRC_URI_append_libc-musl = "\
29 file://0001-fix-build-for-musl-targets.patch \
30"
31SRC_URI[md5sum] = "4ea62074da73ae82e0162d6550d3f129"
32SRC_URI[sha256sum] = "6c396271a8c1ddd5a6fb9abe714ea1e8a86fce85b30ab26b4266aeb4c2413b42"
33
34COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
35
36# valgrind supports armv7 and above
37COMPATIBLE_HOST_armv4 = 'null'
38COMPATIBLE_HOST_armv5 = 'null'
39COMPATIBLE_HOST_armv6 = 'null'
40
41# valgrind doesn't like mips soft float
42COMPATIBLE_HOST_mips = "${@bb.utils.contains("TARGET_FPU", "soft", "null", ".*-linux", d)}"
43COMPATIBLE_HOST_mipsel = "${@bb.utils.contains("TARGET_FPU", "soft", "null", ".*-linux", d)}"
44
45inherit autotools ptest
46
47EXTRA_OECONF = "--enable-tls --without-mpicc"
48EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS', True) != '32']}"
49
50# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
51EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
52
53EXTRA_OEMAKE = "-w"
54
55# valgrind likes to control its own optimisation flags. It generally defaults
56# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
57# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
58# which fixes build path issue in DWARF.
59SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
60
61CFLAGS_append_libc-uclibc = " -D__UCLIBC__ "
62
63do_install_append () {
64 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
65}
66
67RDEPENDS_${PN} += "perl"
68
69# valgrind needs debug information for ld.so at runtime in order to
70# redirect functions like strlen.
71RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
72
73RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
74RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
75
76# One of the tests contains a bogus interpreter path on purpose.
77# Skip file dependency check
78SKIP_FILEDEPS_${PN}-ptest = '1'
79
80do_compile_ptest() {
81 oe_runmake check
82}
83
84do_install_ptest() {
85 chmod +x ${B}/tests/vg_regtest
86
87 # The test application binaries are not automatically installed.
88 # Grab them from the build directory.
89 #
90 # The regression tests require scripts and data files that are not
91 # copied to the build directory. They must be copied from the
92 # source directory.
93 saved_dir=$PWD
94 for parent_dir in ${S} ${B} ; do
95 cd $parent_dir
96
97 # exclude shell or the package won't install
98 rm -rf none/tests/shell* 2>/dev/null
99
100 subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
101
102 # Get the vg test scripts, filters, and expected files
103 for dir in $subdirs ; do
104 find $dir | cpio -pvdu ${D}${PTEST_PATH}
105 done
106 cd $saved_dir
107 done
108
109 # clean out build artifacts before building the rpm
110 find ${D}${PTEST_PATH} \
111 \( -name "Makefile*" \
112 -o -name "*.o" \
113 -o -name "*.c" \
114 -o -name "*.S" \
115 -o -name "*.h" \) \
116 -exec rm {} \;
117
118 # needed by massif tests
119 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
120
121 # handle multilib
122 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
123}