summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-15 16:52:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-11 23:26:31 +0000
commit0ce775acf4b4595a82b690c2bf02a7ee211865a0 (patch)
tree798f43eb75215aead5043298bd8946197f2aed64 /meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
parent21a94f60f60d2b098a05d456264cd5f365469205 (diff)
downloadpoky-0ce775acf4b4595a82b690c2bf02a7ee211865a0.tar.gz
valgrind: update to 3.11.0
LICENSE checksums are changed due to a change in FSF address, or copyright years update. Added patches: 0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch replaces remove-ppc-tests-failing-build.patch and removes only those tests that are known to break the build on ppc32 configurations tested by poky autobuilders Rebased patches: sepbuildfix.patch rebased to 0004-Fix-out-of-tree-builds.patch add-ptest.patch rebased to 0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch Removed patches: force-nostabs.patch removed because it's patching lines that have been removed upstream remove-ppc-tests-failing-build.patch replaced with 0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch enable.building.on.4.x.kernel.patch removed because the problem is fixed upstream glibc.patch removed for the same reason Removed backports: pass-maltivec-only-if-it-supported.patch 0001-valgrind-Enable-rt_sigpending-syscall-on-ppc64-linux.patch (From OE-Core rev: 9ce9c157a61442dc19fc5c6ef2737d2583fa6284) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.11.0.bb')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.11.0.bb105
1 files changed, 105 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
new file mode 100644
index 0000000000..575db35680
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
@@ -0,0 +1,105 @@
1SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=1;endline=29;md5=ebb8e640ef633f940c425686c873f9fa \
7 file://include/valgrind.h;beginline=1;endline=56;md5=4b5e24908e53016ea561c45f4234a327 \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://remove-arm-variant-specific.patch \
19 file://run-ptest \
20 file://11_mips-link-tool.patch \
21 file://0002-remove-rpath.patch \
22 file://0004-Fix-out-of-tree-builds.patch \
23 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
24 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
25 "
26
27SRC_URI[md5sum] = "4ea62074da73ae82e0162d6550d3f129"
28SRC_URI[sha256sum] = "6c396271a8c1ddd5a6fb9abe714ea1e8a86fce85b30ab26b4266aeb4c2413b42"
29
30COMPATIBLE_HOST = '(i.86|x86_64|arm|mips|powerpc|powerpc64).*-linux'
31
32inherit autotools ptest
33
34EXTRA_OECONF = "--enable-tls --without-mpicc"
35EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS', True) != '32']}"
36
37# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
38EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
39
40EXTRA_OEMAKE = "-w"
41
42CFLAGS_append_libc-uclibc = " -D__UCLIBC__ "
43
44do_install_append () {
45 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
46}
47
48RDEPENDS_${PN} += "perl"
49
50# valgrind needs debug information for ld.so at runtime in order to
51# redirect functions like strlen.
52RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
53
54RDEPENDS_${PN}-ptest += " sed perl glibc-utils perl-module-file-glob"
55
56# One of the tests contains a bogus interpreter path on purpose, and QA
57# check complains about it
58INSANE_SKIP_${PN}-ptest += "file-rdeps"
59
60do_compile_ptest() {
61 oe_runmake check CFLAGS="${CFLAGS} -O0" CXXFLAGS="${CXXFLAGS} -O0"
62}
63
64
65do_install_ptest() {
66 chmod +x ${B}/tests/vg_regtest
67
68 # The test application binaries are not automatically installed.
69 # Grab them from the build directory.
70 #
71 # The regression tests require scripts and data files that are not
72 # copied to the build directory. They must be copied from the
73 # source directory.
74 saved_dir=$PWD
75 for parent_dir in ${S} ${B} ; do
76 cd $parent_dir
77
78 # exclude shell or the package won't install
79 rm -rf none/tests/shell* 2>/dev/null
80
81 subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
82
83 # Get the vg test scripts, filters, and expected files
84 for dir in $subdirs ; do
85 find $dir | cpio -pvdu ${D}${PTEST_PATH}
86 done
87 cd $saved_dir
88 done
89
90 # clean out build artifacts before building the rpm
91 find ${D}${PTEST_PATH} \
92 \( -name "Makefile*" \
93 -o -name "*.o" \
94 -o -name "*.c" \
95 -o -name "*.S" \
96 -o -name "*.h" \) \
97 -exec rm {} \;
98
99 # needed by massif tests
100 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
101
102 # handle multilib
103 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
104}
105