diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2016-06-12 01:25:12 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-06-15 08:35:00 +0100 |
commit | 632b7738e618af4ac9d08ea0b5346c8b705a82b3 (patch) | |
tree | 5786c36912c5dff77b555238bf14020540962bdf /meta/recipes-devtools/tcltk/tcl_8.6.5.bb | |
parent | e5043dbbccd05e27d0a020215c38de2be4829187 (diff) | |
download | poky-632b7738e618af4ac9d08ea0b5346c8b705a82b3.tar.gz |
tcl: 8.6.4 -> 8.6.5
(From OE-Core rev: 0d388ca6775318143f62be9310fa2583fc84320f)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.6.5.bb')
-rw-r--r-- | meta/recipes-devtools/tcltk/tcl_8.6.5.bb | 99 |
1 files changed, 99 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.5.bb b/meta/recipes-devtools/tcltk/tcl_8.6.5.bb new file mode 100644 index 0000000000..46fc8a784f --- /dev/null +++ b/meta/recipes-devtools/tcltk/tcl_8.6.5.bb | |||
@@ -0,0 +1,99 @@ | |||
1 | SUMMARY = "Tool Command Language" | ||
2 | HOMEPAGE = "http://tcl.sourceforge.net" | ||
3 | SECTION = "devel/tcltk" | ||
4 | |||
5 | # http://www.tcl.tk/software/tcltk/license.html | ||
6 | LICENSE = "tcl & BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://../license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
8 | file://../compat/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
9 | file://../library/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
10 | file://../macosx/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
11 | file://../tests/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
12 | file://../win/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
13 | " | ||
14 | |||
15 | DEPENDS = "tcl-native zlib" | ||
16 | |||
17 | BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/${BPN}${PV}-src.tar.gz \ | ||
18 | file://tcl-add-soname.patch" | ||
19 | SRC_URI = "${BASE_SRC_URI} \ | ||
20 | file://fix_non_native_build_issue.patch \ | ||
21 | file://fix_issue_with_old_distro_glibc.patch \ | ||
22 | file://no_packages.patch \ | ||
23 | file://tcl-remove-hardcoded-install-path.patch \ | ||
24 | file://alter-includedir.patch \ | ||
25 | file://run-ptest \ | ||
26 | " | ||
27 | SRC_URI[md5sum] = "0e6426a4ca9401825fbc6ecf3d89a326" | ||
28 | SRC_URI[sha256sum] = "ce26d5b9c7504fc25d2f10ef0b82b14cf117315445b5afa9e673ed331830fb53" | ||
29 | |||
30 | SRC_URI_class-native = "${BASE_SRC_URI}" | ||
31 | |||
32 | S = "${WORKDIR}/${BPN}${PV}/unix" | ||
33 | |||
34 | VER = "${PV}" | ||
35 | |||
36 | inherit autotools ptest binconfig | ||
37 | |||
38 | DEPENDS_class-native = "zlib-native" | ||
39 | |||
40 | EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}" | ||
41 | |||
42 | do_configure() { | ||
43 | cd ${S} | ||
44 | gnu-configize | ||
45 | cd ${B} | ||
46 | oe_runconf | ||
47 | } | ||
48 | |||
49 | do_compile_prepend() { | ||
50 | echo > ${S}/../compat/fixstrtod.c | ||
51 | } | ||
52 | |||
53 | do_install() { | ||
54 | autotools_do_install install-private-headers | ||
55 | ln -sf ./tclsh${VER} ${D}${bindir}/tclsh | ||
56 | ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER} | ||
57 | sed -i "s+-L${B}+-L${STAGING_LIBDIR}+g" tclConfig.sh | ||
58 | sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh | ||
59 | sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh | ||
60 | sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh | ||
61 | install -d ${D}${bindir_crossscripts} | ||
62 | install -m 0755 tclConfig.sh ${D}${bindir_crossscripts} | ||
63 | install -m 0755 tclConfig.sh ${D}${libdir} | ||
64 | cd .. | ||
65 | for dir in compat generic unix; do | ||
66 | install -d ${D}${includedir}/${BPN}${VER}/$dir | ||
67 | install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/${BPN}${VER}/$dir/ | ||
68 | done | ||
69 | } | ||
70 | |||
71 | SYSROOT_DIRS += "${bindir_crossscripts}" | ||
72 | |||
73 | PACKAGES =+ "tcl-lib" | ||
74 | FILES_tcl-lib = "${libdir}/libtcl8.6.so.*" | ||
75 | FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8.6 ${libdir}/tcl8" | ||
76 | FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh" | ||
77 | |||
78 | # isn't getting picked up by shlibs code | ||
79 | RDEPENDS_${PN} += "tcl-lib" | ||
80 | RDEPENDS_${PN}_class-native = "" | ||
81 | RDEPENDS_${PN}-ptest += "libgcc" | ||
82 | |||
83 | BBCLASSEXTEND = "native" | ||
84 | |||
85 | do_compile_ptest() { | ||
86 | oe_runmake tcltest | ||
87 | } | ||
88 | |||
89 | do_install_ptest() { | ||
90 | cp ${B}/tcltest ${D}${PTEST_PATH} | ||
91 | cp -r ${S}/../library ${D}${PTEST_PATH} | ||
92 | cp -r ${S}/../tests ${D}${PTEST_PATH} | ||
93 | } | ||
94 | |||
95 | # Fix some paths that might be used by Tcl extensions | ||
96 | BINCONFIG_GLOB = "*Config.sh" | ||
97 | |||
98 | # Fix the path in sstate | ||
99 | SSTATE_SCAN_FILES += "*Config.sh" | ||