summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_231.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-12-26 16:10:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-16 18:05:12 +0000
commit5c9aaf36d6e886da142ea52bde0b889d02756e10 (patch)
tree571b132a62e79aed4e620925b7b608b51e43123e /meta/recipes-devtools/systemd-bootchart/systemd-bootchart_231.bb
parent4e2421419b4c903e0c634212d27a02177250c2ff (diff)
downloadpoky-5c9aaf36d6e886da142ea52bde0b889d02756e10.tar.gz
systemd-bootchart: upgrade to 231
(From OE-Core rev: b4dccaf03ed4d01f6b41518f391948bbb6789f72) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/systemd-bootchart/systemd-bootchart_231.bb')
-rw-r--r--meta/recipes-devtools/systemd-bootchart/systemd-bootchart_231.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_231.bb b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_231.bb
new file mode 100644
index 0000000000..1d8803616a
--- /dev/null
+++ b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_231.bb
@@ -0,0 +1,29 @@
1LICENSE = "LGPLv2.1 & GPLv2"
2LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
3 file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
4
5SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https"
6
7# Modify these as desired
8PV = "231+git${SRCPV}"
9SRCREV = "9ee2ffc1dc6c8209725e625954bbd89f96cb7139"
10
11S = "${WORKDIR}/git"
12
13DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
14
15inherit pkgconfig autotools systemd distro_features_check
16
17REQUIRED_DISTRO_FEATURES = "systemd"
18
19SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
20
21do_configure_prepend() {
22 # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
23 rm -f ${S}/m4/intltool.m4
24}
25
26FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
27
28EXTRA_OECONF = " --with-rootprefix=${base_prefix} \
29 --with-rootlibdir=${base_libdir}"