summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_5.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-08-06 16:17:34 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-08 09:17:49 +0100
commitdb05c02af4dfcbfa789b0d5a4fae00766f7104db (patch)
tree291a59c3d9e27537086adc90d33cc3d347939977 /meta/recipes-devtools/strace/strace_5.8.bb
parent24f830fc75f46f4c9e87a757713e09cf91d76a73 (diff)
downloadpoky-db05c02af4dfcbfa789b0d5a4fae00766f7104db.tar.gz
strace: update to 5.8 (fix build against v5.8 uapi headers)
Updating strace to the 5.8 release. The signficant change in this release is fixes to build against the v5.8 kernel. Noteworthy changes from the strace site: - Changes in behaviour - Modified %process class to contain system calls associated with process lifecycle (creation, exec, termination): kill, tkill, tgkill, pidfd_send_signal and rt_sigqueueinfo are added, arch_prctl and unshare are removed. - Improvements - Implemented decoding of faccessat2 syscall. - Implemented decoding of LOOP_CONFIGURE ioctl command. - Updated decoding of io_uring_setup syscall to match Linux 5.8. - Updated lists of AUDIT_*, BPF_*, CAP_*, ETH_*, INET_DIAG_*, IORING_*, KEYCTL_*, KVM_*, LOOP_*, NDA_*, RTC_*, TCA_*, STATX_*, and *_MAGIC constants. - Updated lists of ioctl commands from Linux 5.8. - Bug fixes - Added statx syscall to %fstat trace class. (From OE-Core rev: d656936ec7fbd4c2748a8f2239b6c09e5b9216d9) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_5.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_5.8.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_5.8.bb b/meta/recipes-devtools/strace/strace_5.8.bb
new file mode 100644
index 0000000000..70d5940f60
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_5.8.bb
@@ -0,0 +1,55 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.io"
3SECTION = "console/utils"
4LICENSE = "LGPL-2.1+ & GPL-2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c756d9d5dabc27663df64f0bf492166c"
6
7SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://update-gawk-paths.patch \
10 file://Makefile-ptest.patch \
11 file://run-ptest \
12 file://mips-SIGEMT.patch \
13 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
14 file://ptest-spacesave.patch \
15 file://uintptr_t.patch \
16 file://0001-strace-fix-reproducibilty-issues.patch \
17 "
18SRC_URI[sha256sum] = "df4a669f7fff9cc302784085bd4b72fab216a426a3f72c892b28a537b71e7aa9"
19
20inherit autotools ptest
21
22PACKAGECONFIG_class-target ??= "\
23 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
24"
25
26PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
27PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
28
29EXTRA_OECONF += "--enable-mpers=no --disable-gcc-Werror"
30
31CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
32
33TESTDIR = "tests"
34PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)"
35
36do_install_append() {
37 # We don't ship strace-graph here because it needs perl
38 rm ${D}${bindir}/strace-graph
39}
40
41do_compile_ptest() {
42 oe_runmake -C ${TESTDIR} buildtest-TESTS
43}
44
45do_install_ptest() {
46 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
47 install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
48 install -m 644 ${B}/config.h ${D}${PTEST_PATH}
49 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
50}
51
52RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
53
54BBCLASSEXTEND = "native"
55TOOLCHAIN = "gcc"