summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_5.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-11-02 17:48:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:21:11 +0000
commit09f7f44c2e8494b7b188d10b8f3b93d86ee97405 (patch)
treede7b181aee74be95e029abaeaeae063e48e75329 /meta/recipes-devtools/strace/strace_5.8.bb
parentebab3cc8ff1150f8f2554a505862ca8b5fce37a8 (diff)
downloadpoky-09f7f44c2e8494b7b188d10b8f3b93d86ee97405.tar.gz
strace: upgrade 5.8 -> 5.9
(From OE-Core rev: bceb1a78c372118f4640d9396b46739deef4ea1b) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_5.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_5.8.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/recipes-devtools/strace/strace_5.8.bb b/meta/recipes-devtools/strace/strace_5.8.bb
deleted file mode 100644
index 0415588b97..0000000000
--- a/meta/recipes-devtools/strace/strace_5.8.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.io"
3SECTION = "console/utils"
4LICENSE = "LGPL-2.1+ & GPL-2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c756d9d5dabc27663df64f0bf492166c"
6
7SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://update-gawk-paths.patch \
10 file://Makefile-ptest.patch \
11 file://run-ptest \
12 file://mips-SIGEMT.patch \
13 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
14 file://ptest-spacesave.patch \
15 file://uintptr_t.patch \
16 file://0001-strace-fix-reproducibilty-issues.patch \
17 file://0001-xlat-Mark-IPPROTO_MAX-last-in-IPPROTO_-constants.patch \
18 "
19SRC_URI[sha256sum] = "df4a669f7fff9cc302784085bd4b72fab216a426a3f72c892b28a537b71e7aa9"
20
21inherit autotools ptest
22
23PACKAGECONFIG_class-target ??= "\
24 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
25"
26
27PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
28PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
29
30EXTRA_OECONF += "--enable-mpers=no --disable-gcc-Werror"
31
32CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
33
34TESTDIR = "tests"
35PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)"
36
37do_install_append() {
38 # We don't ship strace-graph here because it needs perl
39 rm ${D}${bindir}/strace-graph
40}
41
42do_compile_ptest() {
43 oe_runmake -C ${TESTDIR} buildtest-TESTS
44}
45
46do_install_ptest() {
47 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
48 install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
49 install -m 644 ${B}/config.h ${D}${PTEST_PATH}
50 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
51}
52
53RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
54
55BBCLASSEXTEND = "native"
56TOOLCHAIN = "gcc"