summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_5.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-08 09:46:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-09 13:14:00 +0100
commitdd0fffed83777d10edbe1266051c888450aab5da (patch)
tree898173118512f47bc19db658444327558596cc75 /meta/recipes-devtools/strace/strace_5.7.bb
parent27e5fd82634ecbb81140df9bdfd0e5937cf4f445 (diff)
downloadpoky-dd0fffed83777d10edbe1266051c888450aab5da.tar.gz
strace: upgrade 5.6 -> 5.7
(From OE-Core rev: 38da7f53f9400a8aa1b63884e091e280179dd12d) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_5.7.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_5.7.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_5.7.bb b/meta/recipes-devtools/strace/strace_5.7.bb
new file mode 100644
index 0000000000..c184d035aa
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_5.7.bb
@@ -0,0 +1,55 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.io"
3SECTION = "console/utils"
4LICENSE = "LGPL-2.1+ & GPL-2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c756d9d5dabc27663df64f0bf492166c"
6
7SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://update-gawk-paths.patch \
10 file://Makefile-ptest.patch \
11 file://run-ptest \
12 file://mips-SIGEMT.patch \
13 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
14 file://ptest-spacesave.patch \
15 file://uintptr_t.patch \
16 file://0001-strace-fix-reproducibilty-issues.patch \
17 "
18SRC_URI[sha256sum] = "b284b59f9bcd95b9728cea5bd5c0edc5ebe360af73dc76fbf6334f11c777ccd8"
19
20inherit autotools ptest
21
22PACKAGECONFIG_class-target ??= "\
23 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
24"
25
26PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
27PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
28
29EXTRA_OECONF += "--enable-mpers=no --disable-gcc-Werror"
30
31CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
32
33TESTDIR = "tests"
34PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)"
35
36do_install_append() {
37 # We don't ship strace-graph here because it needs perl
38 rm ${D}${bindir}/strace-graph
39}
40
41do_compile_ptest() {
42 oe_runmake -C ${TESTDIR} buildtest-TESTS
43}
44
45do_install_ptest() {
46 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
47 install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
48 install -m 644 ${B}/config.h ${D}${PTEST_PATH}
49 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
50}
51
52RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
53
54BBCLASSEXTEND = "native"
55TOOLCHAIN = "gcc"