summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_5.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-23 19:43:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-26 08:41:38 +0100
commit3ab89fa06f2ef974eee2734ab582f62c98e0020e (patch)
tree9c306beb8d71b12048e245ec337025d0c287d4fa /meta/recipes-devtools/strace/strace_5.2.bb
parentae4ceea4feb5f52d2784707eb30d1f165d2fb9cf (diff)
downloadpoky-3ab89fa06f2ef974eee2734ab582f62c98e0020e.tar.gz
strace: Upgrade to 5.2
License-Updtate: Copyright years changed https://github.com/strace/strace/commit/4b4a0e5a6e74e16dc2bb9b38d81415d9f57425d2#diff-7116ef0705885343c9e1b2171a06be0e Drop backport patch for mips o32 build fix Refresh patches to apply on 5.2 (From OE-Core rev: abeb32772b8b3a144e468e5a27b1a31f646317e4) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_5.2.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_5.2.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_5.2.bb b/meta/recipes-devtools/strace/strace_5.2.bb
new file mode 100644
index 0000000000..8367bf1a4f
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_5.2.bb
@@ -0,0 +1,57 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.io"
3SECTION = "console/utils"
4LICENSE = "LGPL-2.1+ & GPL-2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0169a04810830e94f4b1cfb823c9f592"
6
7SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
14 file://mips-SIGEMT.patch \
15 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
16 file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \
17 file://ptest-spacesave.patch \
18 "
19SRC_URI[md5sum] = "b9c02b07dcde5125498ce7da69b77baf"
20SRC_URI[sha256sum] = "d513bc085609a9afd64faf2ce71deb95b96faf46cd7bc86048bc655e4e4c24d2"
21
22inherit autotools ptest
23
24PACKAGECONFIG_class-target ??= "\
25 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
26"
27
28PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
29PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
30
31EXTRA_OECONF += "--enable-mpers=no"
32
33CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
34
35TESTDIR = "tests"
36PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)"
37
38do_install_append() {
39 # We don't ship strace-graph here because it needs perl
40 rm ${D}${bindir}/strace-graph
41}
42
43do_compile_ptest() {
44 oe_runmake -C ${TESTDIR} buildtest-TESTS
45}
46
47do_install_ptest() {
48 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
49 install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
50 install -m 644 ${B}/config.h ${D}${PTEST_PATH}
51 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
52}
53
54RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
55
56BBCLASSEXTEND = "native"
57TOOLCHAIN = "gcc"