diff options
author | wangmy <wangmy@fujitsu.com> | 2022-01-17 22:31:43 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-01-18 10:53:54 +0000 |
commit | e25fee2ff8896cfaa41dcf36c9d044164606db04 (patch) | |
tree | 175d7331be62f5edce0e244f95c3107c181a0585 /meta/recipes-devtools/strace/strace_5.16.bb | |
parent | 30260fcccff1e34e11d0adf55a684a8d137ee132 (diff) | |
download | poky-e25fee2ff8896cfaa41dcf36c9d044164606db04.tar.gz |
strace: upgrade 5.15 -> 5.16
License-Update: year updated to 2022.
Changelog:
=========
Improvements
-----------
-Implemented --secontext=mismatch option to find mismatches in SELinux contexts.
-Implemented decoding of futex_waitv syscall introduced in Linux 5.16.
-Implemented decoding of BPF_LINK_GET_NEXT_ID and BPF_LINK_GET_FD_BY_ID bpf
syscall commands.
-Enhanced decoding of BPF_MAP_CREATE, BPF_PROG_TEST_RUN, and BPF_PROG_LOAD
bpf syscall commands.
-Enhanced decoding of BTRFS_IOC_FS_INFO ioctl command.
-Updated lists of AUDIT_*, BPF_*, BTRFS_*, DEVCONF_*, FAN_*, ETH_P_*,
IPV4_DEVCONF_*, KVM_*, NDA_*, SO_*, and V4L2_* constants.
-Updated lists of ioctl commands from Linux 5.16.
Bug fixes
---------
-Fixed build for older Android.
(From OE-Core rev: e213db717fa274db6dcab6f0b6b0728a87b8d803)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_5.16.bb')
-rw-r--r-- | meta/recipes-devtools/strace/strace_5.16.bb | 54 |
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_5.16.bb b/meta/recipes-devtools/strace/strace_5.16.bb new file mode 100644 index 0000000000..1874ef1017 --- /dev/null +++ b/meta/recipes-devtools/strace/strace_5.16.bb | |||
@@ -0,0 +1,54 @@ | |||
1 | SUMMARY = "System call tracing tool" | ||
2 | HOMEPAGE = "http://strace.io" | ||
3 | DESCRIPTION = "strace is a diagnostic, debugging and instructional userspace utility for Linux. It is used to monitor and tamper with interactions between processes and the Linux kernel, which include system calls, signal deliveries, and changes of process state." | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "LGPL-2.1+ & GPL-2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59a33f0a3e6122d67c0b3befccbdaa6b" | ||
7 | |||
8 | SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \ | ||
9 | file://update-gawk-paths.patch \ | ||
10 | file://Makefile-ptest.patch \ | ||
11 | file://run-ptest \ | ||
12 | file://mips-SIGEMT.patch \ | ||
13 | file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \ | ||
14 | file://ptest-spacesave.patch \ | ||
15 | file://0001-strace-fix-reproducibilty-issues.patch \ | ||
16 | " | ||
17 | SRC_URI[sha256sum] = "dc7db230ff3e57c249830ba94acab2b862da1fcaac55417e9b85041a833ca285" | ||
18 | |||
19 | inherit autotools ptest | ||
20 | |||
21 | PACKAGECONFIG:class-target ??= "\ | ||
22 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ | ||
23 | " | ||
24 | |||
25 | PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5" | ||
26 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" | ||
27 | |||
28 | EXTRA_OECONF += "--enable-mpers=no --disable-gcc-Werror" | ||
29 | |||
30 | CFLAGS:append:libc-musl = " -Dsigcontext_struct=sigcontext" | ||
31 | |||
32 | TESTDIR = "tests" | ||
33 | PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)" | ||
34 | |||
35 | do_compile_ptest() { | ||
36 | oe_runmake ${PARALLEL_MAKE} -C ${TESTDIR} buildtest-TESTS | ||
37 | } | ||
38 | |||
39 | do_install_ptest() { | ||
40 | oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR} | ||
41 | mkdir -p ${D}${PTEST_PATH}/build-aux | ||
42 | mkdir -p ${D}${PTEST_PATH}/src | ||
43 | install -m 755 ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/ | ||
44 | install -m 644 ${B}/src/config.h ${D}${PTEST_PATH}/src/ | ||
45 | sed -i -e '/^src/s/strace.*[0-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile | ||
46 | } | ||
47 | |||
48 | RDEPENDS:${PN}-ptest += "make coreutils grep gawk sed" | ||
49 | |||
50 | RDEPENDS:${PN}-ptest:append:libc-glibc = "\ | ||
51 | locale-base-en-us.iso-8859-1 \ | ||
52 | " | ||
53 | |||
54 | BBCLASSEXTEND = "native" | ||