summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.25.bb
diff options
context:
space:
mode:
authorMauno Niko <niko.mauno@vaisala.com>2018-11-12 11:32:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-14 11:14:39 +0000
commitf616a6031d3f9324e6da53835b0691fe5bd18278 (patch)
tree46e03e6ce2e943152e425fe7efc9e9384f3c3453 /meta/recipes-devtools/strace/strace_4.25.bb
parentf885c4cd7f1be3bad417a4c15b19062e47355922 (diff)
downloadpoky-f616a6031d3f9324e6da53835b0691fe5bd18278.tar.gz
strace: Bump to version 4.25
V4L2_CID_USER_IMX_BASE value differs in v4.14 and v4.19 LTS kernels https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/tree/include/uapi/linux/v4l2-controls.h?h=v4.14.79#n191 https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/tree/include/uapi/linux/v4l2-controls.h?h=v4.19.1#n191 Building strace v4.24 against 4.19 kernel headers results in following build failure | arm-vaisala-linux-gnueabi-ranlib libstrace.a | In file included from ../strace-4.24/static_assert.h:31, | from ../strace-4.24/xlat/v4l2_pix_fmts.h:4, | from ../strace-4.24/v4l2.c:78: | ../strace-4.24/xlat/v4l2_control_id_bases.h:36:1: error: static assertion failed: "V4L2_CID_USER_IMX_BASE != (V4L2_CID_BASE + 0x1090)" This Linux kernel ABI breakage that occurred wrt V4L2_CID_USER_IMX_BASE has been observed and addressed in strace upstream commit https://github.com/strace/strace/commit/b89a69dec27cf638df0e17db80ed937c3e1abf77 Bump strace to version 4.25 which also addresses ABI breakage so that strace once again builds against both v4.14 and v4.19 LTS kernel headers (From OE-Core rev: facb6e2fd887d526e031b6c16b4bb8d385db952a) Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.25.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.25.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.25.bb b/meta/recipes-devtools/strace/strace_4.25.bb
new file mode 100644
index 0000000000..117ebfbf72
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.25.bb
@@ -0,0 +1,64 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.io"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6ddb91734b9c705f3e87362e97e5f64b"
6
7SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
14 file://mips-SIGEMT.patch \
15 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
16 file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \
17 "
18SRC_URI[md5sum] = "fa5ac841e9ce6af133061822898d49a9"
19SRC_URI[sha256sum] = "d685f8e65470b7832c3aff60c57ab4459f26ff89f07c10f92bd70ee89efac701"
20
21inherit autotools ptest bluetooth
22
23PACKAGECONFIG_class-target ??= "\
24 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
25"
26
27PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
28PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
29
30EXTRA_OECONF += "--enable-mpers=no"
31
32CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
33
34TESTDIR = "tests"
35
36do_install_append() {
37 # We don't ship strace-graph here because it needs perl
38 rm ${D}${bindir}/strace-graph
39}
40
41do_compile_ptest() {
42 oe_runmake -C ${TESTDIR} buildtest-TESTS
43}
44
45do_install_ptest() {
46 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
47 install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
48 install -m 644 ${B}/config.h ${D}${PTEST_PATH}
49 sed -i -e '/^src/s/strace.*[1-9]/ptest/' \
50 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
51 -e 's|${DEBUG_PREFIX_MAP}||g' \
52 -e 's:${HOSTTOOLS_DIR}/::g' \
53 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
54 -e 's:${RECIPE_SYSROOT}::g' \
55 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
56 -e '/^DEB_CHANGELOGTIME/d' \
57 -e '/^RPM_CHANGELOGTIME/d' \
58 ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
59}
60
61RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
62
63BBCLASSEXTEND = "native"
64TOOLCHAIN = "gcc"