summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.18.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-08-21 01:00:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 08:47:03 +0100
commitef4c6534ff5f5c0d81d753239800a9cd06c9d6db (patch)
treec4db34e8b7b638ab48d4304b73f04735d7c0d6a4 /meta/recipes-devtools/strace/strace_4.18.bb
parent08975348f19428c7bb39d497a7d738f90b25ae7b (diff)
downloadpoky-ef4c6534ff5f5c0d81d753239800a9cd06c9d6db.tar.gz
strace: 4.17 -> 4.18
- Updated update-gawk-paths.patch. - Updated Makefile-ptest.patch - Removed 0008-replace-struct-ucontext-with-ucontext_t.patch which is already in the source. - The LIC_FILES_CHKSUM is changed because the years have been updated, the contents are the same. (From OE-Core rev: 111e4a8642160c8441e447da32a4ef52995bbe99) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.18.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.18.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.18.bb b/meta/recipes-devtools/strace/strace_4.18.bb
new file mode 100644
index 0000000000..bbb82a9d84
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.18.bb
@@ -0,0 +1,49 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f132b4d2adfccc63da4139a609367711"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
14 file://mips-SIGEMT.patch \
15 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
16 "
17
18SRC_URI[md5sum] = "3579b3266bb096cebaefbe2cdb1a3a78"
19SRC_URI[sha256sum] = "89ad887c1e6226bdbca8da31d589cadea4be0744b142eb47b768086c937fca08"
20
21inherit autotools ptest bluetooth
22
23RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
24
25PACKAGECONFIG_class-target ??= "\
26 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
27"
28
29PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
30PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
31
32TESTDIR = "tests"
33
34do_install_append() {
35 # We don't ship strace-graph here because it needs perl
36 rm ${D}${bindir}/strace-graph
37}
38
39do_compile_ptest() {
40 oe_runmake -C ${TESTDIR} buildtest-TESTS
41}
42
43do_install_ptest() {
44 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
45 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
46}
47
48BBCLASSEXTEND = "native"
49TOOLCHAIN = "gcc"