summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.12.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-06-12 01:25:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:35:01 +0100
commit559dba8cc0090524da2599fb0818bf8e8bf4d3c8 (patch)
tree76ed2d150ccabdf3c5372659ff450cc80138ac59 /meta/recipes-devtools/strace/strace_4.12.bb
parent632b7738e618af4ac9d08ea0b5346c8b705a82b3 (diff)
downloadpoky-559dba8cc0090524da2599fb0818bf8e8bf4d3c8.tar.gz
strace: 4.11 -> 4.12
* Remove backported patches: 0001-Move-gcc-compat-macros-to-gcc_compat.h.patch 0001-arc-metag-nios2-or1k-tile-fix-build.patch 0001-scm_rights-fd.test-rewrite-without-fork.patch 0001-tests-introduce-libtests.patch 0001-tests-scm_rights.c-use-libtests.patch * Update update-gawk-paths.patch (From OE-Core rev: 53b3d06d24ad711241fe706d100d888a06669d57) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.12.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.12.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.12.bb b/meta/recipes-devtools/strace/strace_4.12.bb
new file mode 100644
index 0000000000..70d74028de
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.12.bb
@@ -0,0 +1,47 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://use-asm-sgidefs.h.patch \
12 file://Makefile-ptest.patch \
13 file://run-ptest \
14 file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
15 "
16
17SRC_URI[md5sum] = "efb8611fc332e71ec419c53f59faa93e"
18SRC_URI[sha256sum] = "51144b78cb9ba22211b95a5aafe0af3694c0d575b25975d80ca9dd4dfd7c1e59"
19
20inherit autotools ptest bluetooth
21
22RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
23
24PACKAGECONFIG_class-target ??= "\
25 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
26"
27
28PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
29PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
30
31TESTDIR = "tests"
32
33do_install_append() {
34 # We don't ship strace-graph here because it needs perl
35 rm ${D}${bindir}/strace-graph
36}
37
38do_compile_ptest() {
39 oe_runmake -C ${TESTDIR} buildtest-TESTS
40}
41
42do_install_ptest() {
43 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
44 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
45}
46
47BBCLASSEXTEND = "native"