summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.11.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-18 13:33:52 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-20 17:07:16 +0000
commit92a003253eeb4ad195bfec8fdb1ab608237690bc (patch)
treec736ebab0fd789918c81c6262c098ef27350bd41 /meta/recipes-devtools/strace/strace_4.11.bb
parent0aa81691009015bb66dcb51935392c6d52f5e5bd (diff)
downloadpoky-92a003253eeb4ad195bfec8fdb1ab608237690bc.tar.gz
strace: update 4.10 -> 4.11
Noteworthy changes in release 4.11 (2015-12-21) =============================================== * Changes in behavior * Some syscalls have different names depending on architecture and personality. In these cases, syscall filtering and printing now consistently uses the names that match corresponding __NR_* kernel macros of the tracee's architecture and personality. * Added strace prefix to all diagnostic messages. * Improvements * Enhanced and extended test suite. * Implemented reliable tracing of processes whose personality differs from the personality of strace, fixed decoding of 32-bit personality syscalls on 64-bit architectures. * When some data referenced by syscall arguments is irrelevant or cannot be read from tracee's memory, strace now prints its address consistently. * When a syscall is restarted using restart_syscall mechanism, strace now shows the syscall name on architectures that expose this information. * Print values returned by epoll_create1, eventfd, eventfd2, fanotify_init, inotify_init1, perf_event_open, pipe, pipe2, signalfd, signalfd4, socket, socketpair, timerfd, and timerfd_create syscalls, as well as F_DUPFD and F_DUPFD_CLOEXEC fcntl commands, as file descriptors. * Optimized decoding of indirect socket syscalls. * Implemented decoding of nanoseconds along with seconds in stat family syscalls (addresses Fedora bug #1251176). * Implemented decoding of struct statfs.f_flags in statfs syscall. * Implemented decoding of siginfo_t.si_syscall and siginfo_t.si_arch in SIGSYS signal. * Implemented decoding of indirect syscall on mips o32. * Implemented decoding of IPPROTO_IP control messages. * Implemented decoding of setsockopt syscall multicast arguments. * Enhanced decoding of struct sigevent. * Enhanced decoding of block, loop, mtd, ptp, rtc, SG_IO, socket, tty, and v4l2 ioctl syscall arguments. * Enhanced decoding of epoll_create, fcntl, fcntl64, futex, getdents, getdents64, getsockopt, io_*, mount, msgctl, prctl, quotactl, recvfrom, sendfile, setsockopt, and shmctl syscalls. * Implemented decoding of bpf, execveat, ioperm, iopl, kcmp, kexec_file_load, lookup_dcookie, membarrier, memfd_create, mlock2, name_to_handle_at, open_by_handle_at, sched_getattr, sched_setattr, and userfaultfd syscalls. * Updated lists of AF_*, EPOLL_*, FALLOC_FL_*, F_*, INPUT_PROP_*, IPPROTO_*, IPV6_*, IP_*, KEY_*, LOCK_*, MNT_*, MS_*, PACKET_*, PERF_FLAG_*, PF_*, PR_*, PTRACE_O_*, RENAME_*, SCTP_*, SECBIT_*, SO_*, TCP_*, and siginfo_t constants. * Added Nios II architecture support. * Added new syscall entries to match Linux 4.4. * Bug fixes * Fixed potential short read of strings from tracee's memory. * Fixed -qq option in conjunction with -o option. * Fixed filtering of <unavailable> syscalls. * Fixed decoding of ioctl syscall command on aarch64 and 32-bit architectures with 64-bit aligned structures. * Fixed decoding of eventfd2, epoll_create1, signalfd4, and sync_file_range2 syscall flags arguments. * Fixed decoding of 4th argument of clock_nanosleep syscall. * Fixed decoding of getpagesize syscall on m68k. * Fixed decoding of getrandom and seccomp syscalls on aarch64. * Fixed decoding of timezone argument of gettimeofday and settimeofday * syscalls. * Fixed decoding of offset argument of mmap2 syscall on arm, sparc, and sparc64. * Fixed decoding of pipe syscall on alpha and mips. * Fixed decoding of pipe2 syscall on ia64, sh, sparc, and sparc64. * Fixed decoding of signal mask argument of pselect6 syscall on x32. * Fixed decoding of signal mask of rt_sigreturn syscall on aarch64, m68k, and x32. * Fixed decoding of 4th argument of semctl indirect syscall. * Fixed decoding of sa_restorer and sa_mask of sigaction syscall on m68k. * Fixed decoding of statfs64 and fstatfs64 syscalls on arm eabi. * Fixed decoding of struct dirent on x32. * Fixed decoding of times syscall return value on mips n32 and x32. * Fixed decoding of path argument of umount2 syscall (addresses Debian bug #785050). * Worked around a kernel bug in tracing privileged executables. * Fixed various errors in mapping between syscall numbers and associated information like the number of syscall arguments, the name of syscall, and syscall decoder. (From OE-Core rev: f3e6bf135b7b69614d1405ad99e1264ea70a9197) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.11.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.11.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.11.bb b/meta/recipes-devtools/strace/strace_4.11.bb
new file mode 100644
index 0000000000..a72a1f9c24
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.11.bb
@@ -0,0 +1,44 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 "
14
15SRC_URI[md5sum] = "a15d2555a7febb56d00c6e1a51c655dc"
16SRC_URI[sha256sum] = "e86a5f6cd8f941f67f3e4b28f4e60f3d9185c951cf266404533210a2e5cd8152"
17
18inherit autotools ptest bluetooth
19
20RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
21
22PACKAGECONFIG_class-target ??= "\
23 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
24"
25
26PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
27PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
28
29TESTDIR = "tests"
30
31do_install_append() {
32 # We don't ship strace-graph here because it needs perl
33 rm ${D}${bindir}/strace-graph
34}
35
36do_compile_ptest() {
37 oe_runmake -C ${TESTDIR} buildtest-TESTS
38}
39
40do_install_ptest() {
41 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
42}
43
44BBCLASSEXTEND = "native"