summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-06-04 14:44:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-08 00:01:19 +0100
commit5e032f1cca6ba22cd6c87d6105b1281620a42539 (patch)
treec4bd0686fe3956aa16ea3a0777ff6745c623c293 /meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
parent44f0c01f31204b0c2d44876b3b20d126b8f49ea2 (diff)
downloadpoky-5e032f1cca6ba22cd6c87d6105b1281620a42539.tar.gz
squashfs-tools: upgrade to newer revision from git
* 4.3 release has nasty hard to reproduce bug in LZO compression which in few cases results in one of these 2 errors: 1) Lseek failure when creating the FS: | writer: Lseek on destination failed because Bad file descriptor, offset=0x1f72306 | FATAL ERROR:Probably out of space on output filesystem | Parallel mksquashfs: Using 32 processors | Creating 4.0 filesystem on rootfs.squashfs, block size 262144. .. 2) failing to read the filesystem in runtime, kernel 3.16.0 showing errors like this: [ 46.720568] SQUASHFS error: lzo decompression failed, data probably corrupt [ 46.730003] SQUASHFS error: squashfs_read_data failed to read block 0x1f72305 [ 46.740076] SQUASHFS error: Unable to read fragment cache entry [1f72305] it's fixed in upstream git repo: https://github.com/plougher/squashfs-tools/commit/de03266983ceb62e5365aac84fcd3b2fd4d16e6f https://github.com/plougher/squashfs-tools/commit/9c1db6d13a51a2e009f0027ef336ce03624eac0d the official repo is: https://git.kernel.org/cgit/fs/squashfs/squashfs-tools.git but author's github is kept in sync so we can use just that (From OE-Core rev: d0b098a4174ed5d3d61875a3b789d4477ae107ed) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
deleted file mode 100644
index 19d555e1e9..0000000000
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
5LICENSE = "GPL-2 & PD"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
8 "
9DEPENDS = "attr zlib xz lzo lz4"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \
12 http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
13 "
14
15SRC_URI[squashfs.md5sum] = "d92ab59aabf5173f2a59089531e30dbf"
16SRC_URI[squashfs.sha256sum] = "0d605512437b1eb800b4736791559295ee5f60177e102e4d4ccd0ee241a5f3f6"
17
18SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
19SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
20
21S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
22SPDX_S = "${WORKDIR}/squashfs${PV}"
23
24# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
25# the -e causes problems as CFLAGS is modified in the Makefile, so
26# we redefine EXTRA_OEMAKE here
27EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1"
28
29do_compile() {
30 oe_runmake mksquashfs unsquashfs
31}
32do_install () {
33 install -d ${D}${sbindir}
34 install -m 0755 mksquashfs ${D}${sbindir}/
35 install -m 0755 unsquashfs ${D}${sbindir}/
36}
37
38ARM_INSTRUCTION_SET = "arm"
39
40BBCLASSEXTEND = "native nativesdk"