summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb')
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
new file mode 100644
index 0000000000..6098673a35
--- /dev/null
+++ b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
@@ -0,0 +1,68 @@
1SUMMARY = "Base utilities for working with SGML and XML"
2DESCRIPTION = "The sgml-common package gathers very basic \
3stuff necessary to work with SGML and XML, such as xml.dcl, \
4a SGML declaration of XML; iso-entities, a list of the basic \
5SGML ISO entities; and install-catalog, a script used to \
6add entries to (or remove entries from) centralized catalogs \
7whose entries are pointers to SGML open catalogs, \
8as defined by OASIS."
9HOMEPAGE = "http://sources.redhat.com/docbook-tools/"
10LICENSE = "GPLv2+"
11# See the comments in license.patch when upgrading this recipe.
12# This is inteded to be a temporary workaround.
13LIC_FILES_CHKSUM = "file://LICENSE-GPLv2;md5=ab8a50abe86dfc859e148baae043c89b"
14SECTION = "base"
15
16PR = "r1"
17
18SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/sgml-common-${PV}.tgz \
19 file://autohell.patch \
20 file://license.patch"
21
22SRC_URI[md5sum] = "103c9828f24820df86e55e7862e28974"
23SRC_URI[sha256sum] = "7dc418c1d361123ffc5e45d61f1b97257940a8eb35d0bfbbc493381cc5b1f959"
24
25inherit autotools
26
27do_compile_append() {
28 # install-catalog script contains hardcoded references to /etc/sgml
29 sed -i -e 's|\([ "]\+\)/etc/sgml|\1${sysconfdir}/sgml|g' bin/install-catalog
30}
31
32FILES_${PN} += "${datadir}/sgml"
33
34pkg_postinst_${PN}() {
35 if [ "x$D" = "x" ]; then
36 install-catalog \
37 --add ${sysconfdir}/sgml/sgml-ent.cat \
38 ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
39
40 install-catalog \
41 --add ${sysconfdir}/sgml/sgml-docbook.cat \
42 ${sysconfdir}/sgml/sgml-ent.cat
43 else
44 if ! grep -q ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog $D${sysconfdir}/sgml/sgml-ent.cat; then
45 echo "CATALOG ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog" >> $D${sysconfdir}/sgml/sgml-ent.cat
46 fi
47 if ! grep -q ${sysconfdir}/sgml/sgml-ent.cat $D${sysconfdir}/sgml/catalog; then
48 echo "CATALOG ${sysconfdir}/sgml/sgml-ent.cat" >> $D${sysconfdir}/sgml/catalog
49 fi
50
51 if ! grep -q ${sysconfdir}/sgml/sgml-ent.cat $D${sysconfdir}/sgml/sgml-docbook.cat; then
52 echo "CATALOG ${sysconfdir}/sgml/sgml-ent.cat" >> $D${sysconfdir}/sgml/sgml-docbook.cat
53 fi
54 if ! grep -q ${sysconfdir}/sgml/sgml-docbook.cat $D${sysconfdir}/sgml/catalog; then
55 echo "CATALOG ${sysconfdir}/sgml/sgml-docbook.cat" >> $D${sysconfdir}/sgml/catalog
56 fi
57 fi
58}
59
60pkg_postrm_${PN}() {
61 install-catalog \
62 --remove ${sysconfdir}/sgml/sgml-ent.cat \
63 ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
64
65 install-catalog \
66 --remove ${sysconfdir}/sgml/sgml-docbook.cat \
67 ${sysconfdir}/sgml/sgml-ent.cat
68}