diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2016-09-30 12:52:25 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-10-28 16:15:19 +0100 |
commit | 671780de49f93ec1cc28f5ad2a7eebe211918b85 (patch) | |
tree | 42ebe78d73a3f0a0fa49fb83ff1f2e557c9dc505 /meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb | |
parent | d95ef2a0aa3116783cd01a905b46fc4920ebae9f (diff) | |
download | poky-671780de49f93ec1cc28f5ad2a7eebe211918b85.tar.gz |
Remove the SGML stack
It is not used for anything, and is something of a pain to maintain.
(From OE-Core rev: 4814d93646f6b86aaffbd3fca1af29c8c577db5b)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb')
-rw-r--r-- | meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb | 70 |
1 files changed, 0 insertions, 70 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb deleted file mode 100644 index 97b308a88b..0000000000 --- a/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb +++ /dev/null | |||
@@ -1,70 +0,0 @@ | |||
1 | SUMMARY = "Base utilities for working with SGML and XML" | ||
2 | DESCRIPTION = "The sgml-common package gathers very basic \ | ||
3 | stuff necessary to work with SGML and XML, such as xml.dcl, \ | ||
4 | a SGML declaration of XML; iso-entities, a list of the basic \ | ||
5 | SGML ISO entities; and install-catalog, a script used to \ | ||
6 | add entries to (or remove entries from) centralized catalogs \ | ||
7 | whose entries are pointers to SGML open catalogs, \ | ||
8 | as defined by OASIS." | ||
9 | HOMEPAGE = "http://sources.redhat.com/docbook-tools/" | ||
10 | LICENSE = "GPLv2+" | ||
11 | # See the comments in license.patch when upgrading this recipe. | ||
12 | # This is inteded to be a temporary workaround. | ||
13 | LIC_FILES_CHKSUM = "file://LICENSE-GPLv2;md5=ab8a50abe86dfc859e148baae043c89b" | ||
14 | SECTION = "base" | ||
15 | |||
16 | PR = "r1" | ||
17 | |||
18 | require sgml-common_${PV}.bb | ||
19 | inherit native | ||
20 | |||
21 | S = "${WORKDIR}/sgml-common-${PV}" | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "sgml_common_native_mangle" | ||
24 | SSTATEPOSTINSTFUNCS += "sgml_common_sstate_postinst" | ||
25 | |||
26 | do_install_append() { | ||
27 | # install-catalog script contains hard-coded references to | ||
28 | # {sysconfdir}. Change it to ${D}${sysconfdir}. | ||
29 | sed -i -e "s|${sysconfdir}/sgml|${D}${sysconfdir}/sgml|g" ${D}${bindir}/install-catalog | ||
30 | |||
31 | ${D}${bindir}/install-catalog \ | ||
32 | --add ${D}${sysconfdir}/sgml/sgml-ent.cat \ | ||
33 | ${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog | ||
34 | |||
35 | # The sgml-docbook.cat will be regenerated by sstate_postinst | ||
36 | rm -f ${D}${sysconfdir}/sgml/sgml-docbook.cat | ||
37 | } | ||
38 | |||
39 | sgml_common_native_mangle () { | ||
40 | # Revert back to ${sysconfdir} path in install-catalog | ||
41 | sed -i -e "s|${D}${sysconfdir}/sgml|${sysconfdir}/sgml|g" ${SYSROOT_DESTDIR}${STAGING_BINDIR}/install-catalog | ||
42 | # Change path from ${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog to ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog in sgml-ent.cat | ||
43 | sed -i -e "s|${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog|${datadir}/sgml/sgml-iso-entities-8879.1986/catalog|g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/sgml-ent.cat | ||
44 | # Remove ${D} path from catalog file created by install-catalog script | ||
45 | sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/catalog | ||
46 | } | ||
47 | |||
48 | sgml_common_sstate_postinst() { | ||
49 | if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ] | ||
50 | then | ||
51 | ${bindir}/install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat ${sysconfdir}/sgml/sgml-ent.cat | ||
52 | if [ -e ${sysconfdir}/sgml/sgml-docbook.bak ]; then | ||
53 | for catalog in `awk '{print $2}' ${sysconfdir}/sgml/sgml-docbook.bak`; do | ||
54 | if [ ! `grep $catalog ${sysconfdir}/sgml/sgml-docbook.cat 1> /dev/null 2>&1` ]; then | ||
55 | ${bindir}/install-catalog \ | ||
56 | --add ${sysconfdir}/sgml/sgml-docbook.cat $catalog | ||
57 | fi | ||
58 | done | ||
59 | fi | ||
60 | cat << EOF > ${SSTATE_INST_POSTRM} | ||
61 | #!/bin/sh | ||
62 | |||
63 | # Ensure that the catalog file sgml-docbook.cat is properly | ||
64 | # updated when the package is removed from sstate cache. | ||
65 | if [ -f ${sysconfdir}/sgml/sgml-docbook.cat ]; then | ||
66 | sed -i '/\/sgml\/sgml-ent.cat/d' ${sysconfdir}/sgml/sgml-docbook.cat | ||
67 | fi | ||
68 | EOF | ||
69 | fi | ||
70 | } | ||