summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-25 17:01:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-26 15:43:43 +0100
commitc5312dd92bd9fd88948567938a0f3b66782ae869 (patch)
tree6fafaa4c430beb023cb75344ec9a3293a2f90392 /meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
parent39b85616adc434fc12aaa260268cebf3b4d9395f (diff)
downloadpoky-c5312dd92bd9fd88948567938a0f3b66782ae869.tar.gz
recipes: Avoid S = WORKDIR
Where recipes use S = ${WORKDIR}, change them to set UNPACKDIR to a subdir of WORKDIR and make S point at this instead. Where WORKDIR is referenced in do_compile/do_install and similar, switch to using ${S} which conceptually makes more sense. (From OE-Core rev: d0c1ae3ffacacc762f957b9b306dfb0a912c4859) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb')
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
index e977942de8..f571e61921 100644
--- a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -8,7 +8,8 @@ SRC_URI = "file://run-postinsts \
8 file://run-postinsts.init \ 8 file://run-postinsts.init \
9 file://run-postinsts.service" 9 file://run-postinsts.service"
10 10
11S = "${WORKDIR}" 11S = "${WORKDIR}/sources"
12UNPACKDIR = "${S}"
12 13
13inherit allarch systemd update-rc.d 14inherit allarch systemd update-rc.d
14 15
@@ -29,13 +30,13 @@ do_compile () {
29 30
30do_install() { 31do_install() {
31 install -d ${D}${sbindir} 32 install -d ${D}${sbindir}
32 install -m 0755 ${WORKDIR}/run-postinsts ${D}${sbindir}/ 33 install -m 0755 ${S}/run-postinsts ${D}${sbindir}/
33 34
34 install -d ${D}${sysconfdir}/init.d/ 35 install -d ${D}${sysconfdir}/init.d/
35 install -m 0755 ${WORKDIR}/run-postinsts.init ${D}${sysconfdir}/init.d/run-postinsts 36 install -m 0755 ${S}/run-postinsts.init ${D}${sysconfdir}/init.d/run-postinsts
36 37
37 install -d ${D}${systemd_system_unitdir}/ 38 install -d ${D}${systemd_system_unitdir}/
38 install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_system_unitdir}/ 39 install -m 0644 ${S}/run-postinsts.service ${D}${systemd_system_unitdir}/
39 40
40 sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \ 41 sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
41 -e 's:#SBINDIR#:${sbindir}:g' \ 42 -e 's:#SBINDIR#:${sbindir}:g' \