summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.5.5.bb
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-10-01 10:54:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-23 16:30:36 +0100
commit7fef74ae95bc8d4342b06974f6a651b5ded81054 (patch)
treebcc9ab5df4382bef931a14df9ebd6d39d878be8b /meta/recipes-devtools/ruby/ruby_2.5.5.bb
parentf82f4fae7effbf178065deed3934aec3fbf5b8b7 (diff)
downloadpoky-7fef74ae95bc8d4342b06974f6a651b5ded81054.tar.gz
ruby: update to v2.6.4
Most patches had to be refreshed Note that we can now drop EXTRA_AUTORECONF += "--exclude=aclocal" from the recipe, as ruby upstream now fully supports runnning aclocal: https://github.com/ruby/ruby/pull/1793/commits/df9bf70cd2275a3ddc3108f392214fcc4a9b0859 https://github.com/ruby/ruby/commit/ec43478f34de262ebdd2922c488e265344b489c3 Also note that 'created.rid' is not being installed anymore since v2.6.0 While additional LICENSEs were added to the recipe, they should always have been mentioned in this recipe, i.e. the license checksum was updated only because: * URLs were updated * new imported components were mentioned (with no new licenses) * formatting was changed * dates were updated (From OE-Core rev: 7124051b3b2e91e81c7b8565104ae9c5bea10be1) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.5.5.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.5.5.bb74
1 files changed, 0 insertions, 74 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.5.5.bb b/meta/recipes-devtools/ruby/ruby_2.5.5.bb
deleted file mode 100644
index 223b0371eb..0000000000
--- a/meta/recipes-devtools/ruby/ruby_2.5.5.bb
+++ /dev/null
@@ -1,74 +0,0 @@
1require ruby.inc
2
3SRC_URI += " \
4 file://0001-configure.ac-check-finite-isinf-isnan-as-macros-firs.patch \
5 file://run-ptest \
6 "
7
8SRC_URI[md5sum] = "7e156fb526b8f4bb1b30a3dd8a7ce400"
9SRC_URI[sha256sum] = "28a945fdf340e6ba04fc890b98648342e3cccfd6d223a48f3810572f11b2514c"
10
11PACKAGECONFIG ??= ""
12PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
13
14PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
15PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp"
16PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
17
18EXTRA_AUTORECONF += "--exclude=aclocal"
19
20EXTRA_OECONF = "\
21 --disable-versioned-paths \
22 --disable-rpath \
23 --disable-dtrace \
24 --enable-shared \
25 --enable-load-relative \
26 --with-pkg-config=pkg-config \
27"
28
29do_install() {
30 oe_runmake 'DESTDIR=${D}' install
31}
32
33do_install_append_class-target () {
34 # Find out rbconfig.rb from .installed.list
35 rbconfig_rb=`grep rbconfig.rb ${B}/.installed.list`
36 # Remove build host directories
37 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \
38 -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
39 -e 's|${DEBUG_PREFIX_MAP}||g' \
40 -e 's:${HOSTTOOLS_DIR}/::g' \
41 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
42 -e 's:${RECIPE_SYSROOT}::g' \
43 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
44 ${D}$rbconfig_rb
45
46 # Find out created.rid from .installed.list
47 created_rid=`grep created.rid ${B}/.installed.list`
48 # Remove build host directories
49 sed -i -e 's:${WORKDIR}::g' ${D}$created_rid
50
51}
52
53do_install_ptest () {
54 cp -rf ${S}/test ${D}${PTEST_PATH}/
55 cp -r ${S}/include ${D}/${libdir}/ruby/
56 test_case_rb=`grep rubygems/test_case.rb ${B}/.installed.list`
57 sed -i -e 's:../../../test/:../../../ptest/test/:g' ${D}/$test_case_rb
58}
59
60PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
61
62SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
63RDEPENDS_${PN}-ri-docs = "${PN}"
64FILES_${PN}-ri-docs += "${datadir}/ri"
65
66SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
67RDEPENDS_${PN}-rdoc = "${PN}"
68FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
69
70FILES_${PN} += "${datadir}/rubygems"
71
72FILES_${PN}-ptest_append_class-target += "${libdir}/ruby/include"
73
74BBCLASSEXTEND = "native"