summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.4.0.bb
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-02-21 11:03:55 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 23:27:11 +0000
commitdb9b183d5c8067fc0eaf96e6c8e0e81258f4ff1c (patch)
tree989228581431b5d418715909b5dfb79c49066306 /meta/recipes-devtools/ruby/ruby_2.4.0.bb
parent365a57f28100eee3d1f51ff40db781451de54d48 (diff)
downloadpoky-db9b183d5c8067fc0eaf96e6c8e0e81258f4ff1c.tar.gz
ruby: upgrade 2.3.3 -> 2.4.0
Two LIC_FILES_CHKSUM checksums changed (COPYING and LEGAL) but LICENSE remains the same. (From OE-Core rev: 2bbad067b6b928d4615df938d0e41fa84e451c15) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.4.0.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.4.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.4.0.bb b/meta/recipes-devtools/ruby/ruby_2.4.0.bb
new file mode 100644
index 0000000000..4d39c47630
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.4.0.bb
@@ -0,0 +1,44 @@
1require ruby.inc
2
3SRC_URI[md5sum] = "7e9485dcdb86ff52662728de2003e625"
4SRC_URI[sha256sum] = "152fd0bd15a90b4a18213448f485d4b53e9f7662e1508190aa5b702446b29e3d"
5
6# it's unknown to configure script, but then passed to extconf.rb
7# maybe it's not really needed as we're hardcoding the result with
8# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
9UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
10
11PACKAGECONFIG ??= ""
12PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
13
14PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
15PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
16PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
17
18EXTRA_AUTORECONF += "--exclude=aclocal"
19
20EXTRA_OECONF = "\
21 --disable-versioned-paths \
22 --disable-rpath \
23 --disable-dtrace \
24 --enable-shared \
25 --enable-load-relative \
26"
27
28do_install() {
29 oe_runmake 'DESTDIR=${D}' install
30}
31
32PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
33
34SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
35RDEPENDS_${PN}-ri-docs = "${PN}"
36FILES_${PN}-ri-docs += "${datadir}/ri"
37
38SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
39RDEPENDS_${PN}-rdoc = "${PN}"
40FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
41
42FILES_${PN} += "${datadir}/rubygems"
43
44BBCLASSEXTEND = "native"