summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.3.1.bb
diff options
context:
space:
mode:
authorEdwin Plauchu <edwin.plauchu.camacho@intel.com>2016-11-25 18:10:40 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:48:09 +0000
commit1d0c124cdf0282b8d139063409e40982f0ec9888 (patch)
treec96ae459a65434ef68db315934fe2d6e5ce40fc0 /meta/recipes-devtools/ruby/ruby_2.3.1.bb
parent7684c803af76ef1cde175d454d1d3bc1c8f84795 (diff)
downloadpoky-1d0c124cdf0282b8d139063409e40982f0ec9888.tar.gz
ruby: upgrade to 2.3.1
(From OE-Core rev: 11063a01d4511b2688ea7ba2d7359e4e07328c66) Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.3.1.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.3.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.3.1.bb b/meta/recipes-devtools/ruby/ruby_2.3.1.bb
new file mode 100644
index 0000000000..299383ad3e
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.3.1.bb
@@ -0,0 +1,44 @@
1require ruby.inc
2
3SRC_URI[md5sum] = "0d896c2e7fd54f722b399f407e48a4c6"
4SRC_URI[sha256sum] = "b87c738cb2032bf4920fef8e3864dc5cf8eae9d89d8d523ce0236945c5797dcd"
5
6# it's unknown to configure script, but then passed to extconf.rb
7# maybe it's not really needed as we're hardcoding the result with
8# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
9UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
10
11PACKAGECONFIG ??= ""
12PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
13
14PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
15PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
16PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
17
18EXTRA_AUTORECONF += "--exclude=aclocal"
19
20EXTRA_OECONF = "\
21 --disable-versioned-paths \
22 --disable-rpath \
23 --disable-dtrace \
24 --enable-shared \
25 --enable-load-relative \
26"
27
28do_install() {
29 oe_runmake 'DESTDIR=${D}' install
30}
31
32PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
33
34SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
35RDEPENDS_${PN}-ri-docs = "${PN}"
36FILES_${PN}-ri-docs += "${datadir}/ri"
37
38SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
39RDEPENDS_${PN}-rdoc = "${PN}"
40FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
41
42FILES_${PN} += "${datadir}/rubygems"
43
44BBCLASSEXTEND = "native"