summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.2.5.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-05-11 10:35:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-13 13:41:31 +0100
commit0dcc42c9abec3d8d4e05904745136564c8aef2c2 (patch)
tree845fe924548f4dbc1113d427bd2bb1a029f4fa6e /meta/recipes-devtools/ruby/ruby_2.2.5.bb
parent278f8e82d682e4ba03b183a751fb2df9c7be64ac (diff)
downloadpoky-0dcc42c9abec3d8d4e05904745136564c8aef2c2.tar.gz
ruby: Upgrade to 2.2.5
This is latest in 2.2 series, helps with compile using clang (From OE-Core rev: 9f1a8cc84105b077cb5896997b220f1f583075b5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.2.5.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.2.5.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.2.5.bb b/meta/recipes-devtools/ruby/ruby_2.2.5.bb
new file mode 100644
index 0000000000..5a645821ba
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.2.5.bb
@@ -0,0 +1,42 @@
1require ruby.inc
2
3SRC_URI[md5sum] = "bd8e349d4fb2c75d90817649674f94be"
4SRC_URI[sha256sum] = "30c4b31697a4ca4ea0c8db8ad30cf45e6690a0f09687e5d483c933c03ca335e3"
5
6# it's unknown to configure script, but then passed to extconf.rb
7# maybe it's not really needed as we're hardcoding the result with
8# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
9UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
10
11PACKAGECONFIG ??= ""
12PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
13
14PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
15PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
16PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
17
18EXTRA_OECONF = "\
19 --disable-versioned-paths \
20 --disable-rpath \
21 --disable-dtrace \
22 --enable-shared \
23 --enable-load-relative \
24"
25
26do_install() {
27 oe_runmake 'DESTDIR=${D}' install
28}
29
30PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
31
32SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
33RDEPENDS_${PN}-ri-docs = "${PN}"
34FILES_${PN}-ri-docs += "${datadir}/ri"
35
36SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
37RDEPENDS_${PN}-rdoc = "${PN}"
38FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
39
40FILES_${PN} += "${datadir}/rubygems"
41
42BBCLASSEXTEND = "native"