summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.2.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-08-23 22:19:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-25 16:00:10 +0100
commit980ab49cdaacb42c19a82ec4cb3e29dab0394eca (patch)
tree0a680160f32305f70f0edd10f850b4adfd2463a6 /meta/recipes-devtools/rsync/rsync_3.2.3.bb
parentb239b50a60a73b7e53fa896afa48ed248fcdc078 (diff)
downloadpoky-980ab49cdaacb42c19a82ec4cb3e29dab0394eca.tar.gz
rsync: upgrade 3.2.2 -> 3.2.3
(From OE-Core rev: 8c315962a08b26f029fbca358b60769657ea0875) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.2.3.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.2.3.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.2.3.bb b/meta/recipes-devtools/rsync/rsync_3.2.3.bb
new file mode 100644
index 0000000000..375efa0dea
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.2.3.bb
@@ -0,0 +1,58 @@
1SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
4SECTION = "console/network"
5# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
6# Includes opennsh and xxhash dynamic link exception
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26"
9
10DEPENDS = "popt"
11
12SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
13 file://rsyncd.conf \
14 file://makefile-no-rebuild.patch \
15 "
16
17SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e"
18
19# -16548 required for v3.1.3pre1. Already in v3.1.3.
20CVE_CHECK_WHITELIST += " CVE-2017-16548 "
21
22inherit autotools-brokensep
23
24PACKAGECONFIG ??= "acl attr \
25 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
26"
27
28PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
29PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
30PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
31PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
32PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
33PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
34PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
35
36# By default, if crosscompiling, rsync disables a number of
37# capabilities, hardlinking symlinks and special files (i.e. devices)
38CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
39
40EXTRA_OEMAKE = 'STRIP=""'
41EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm"
42
43# rsync 3.0 uses configure.sh instead of configure, and
44# makefile checks the existence of configure.sh
45do_configure_prepend () {
46 rm -f ${S}/configure ${S}/configure.sh
47}
48
49do_configure_append () {
50 cp -f ${S}/configure ${S}/configure.sh
51}
52
53do_install_append() {
54 install -d ${D}${sysconfdir}
55 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
56}
57
58BBCLASSEXTEND = "native"