summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.2.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-05-05 07:05:38 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-05 21:17:38 +0100
commit2a39819c3943a0a31b7ab1559f938d7a161795d4 (patch)
treedc5dae81481f1faf41aa388dd24c80259313ecbc /meta/recipes-devtools/rsync/rsync_3.2.3.bb
parent1d9533d4e7c9f6cc39439a09e89e5f8a9a43e028 (diff)
downloadpoky-2a39819c3943a0a31b7ab1559f938d7a161795d4.tar.gz
rsync: update 3.2.3 -> 3.2.4
Drop configure options that have been removed upstream. License-Update: formatting (From OE-Core rev: bc9bf4c2ea4230391fc3ee2f55d1f73e1dd39edf) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.2.3.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.2.3.bb61
1 files changed, 0 insertions, 61 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.2.3.bb b/meta/recipes-devtools/rsync/rsync_3.2.3.bb
deleted file mode 100644
index 6168ee85fc..0000000000
--- a/meta/recipes-devtools/rsync/rsync_3.2.3.bb
+++ /dev/null
@@ -1,61 +0,0 @@
1SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer."
4BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
5SECTION = "console/network"
6# GPL-2.0-or-later (<< 3.0.0), GPL-3.0-or-later (>= 3.0.0)
7# Includes opennsh and xxhash dynamic link exception
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26"
10
11DEPENDS = "popt"
12
13SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
14 file://rsyncd.conf \
15 file://makefile-no-rebuild.patch \
16 file://determism.patch \
17 file://0001-rsync-ssl-Verify-the-hostname-in-the-certificate-whe.patch \
18 "
19
20SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e"
21
22# -16548 required for v3.1.3pre1. Already in v3.1.3.
23CVE_CHECK_IGNORE += " CVE-2017-16548 "
24
25inherit autotools-brokensep
26
27PACKAGECONFIG ??= "acl attr \
28 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
29"
30
31PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
32PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
33PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
34PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
35PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
36PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
37PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
38
39# By default, if crosscompiling, rsync disables a number of
40# capabilities, hardlinking symlinks and special files (i.e. devices)
41CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
42
43EXTRA_OEMAKE = 'STRIP=""'
44EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm --with-nobody-group=nogroup"
45
46# rsync 3.0 uses configure.sh instead of configure, and
47# makefile checks the existence of configure.sh
48do_configure:prepend () {
49 rm -f ${S}/configure ${S}/configure.sh
50}
51
52do_configure:append () {
53 cp -f ${S}/configure ${S}/configure.sh
54}
55
56do_install:append() {
57 install -d ${D}${sysconfdir}
58 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
59}
60
61BBCLASSEXTEND = "native nativesdk"